0

I am having problem with dedicated server I am hosting on Hetzner. I had similar problem few years before with other dedicated one and I am worried if this thing is my fault or someone other's.

It just hangs up. I can't login via SSH to it, open webpages (Timeout). I then have to hard-reset it via their administration tools. The last thing in /var/log/syslog is a CRON message (which otherwise works okay) and then a line of NULL chars ^@ followed by reboot initialized by myself.

How do I check what may be wrong? I tried memtester and it all went ok. I also tried googling for this a lot but found no useful answers. Oh and it is Linux 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u6 (2018-10-08) x86_64 GNU/Linux

What else can I do?

  • If you can wait for another "hang", try with sysdig and see what you'll find in its logs. – titus Jan 1 '19 at 20:20
  • @anx yes and yes – Martin. Jan 2 '19 at 17:05
  • @titus how do I check sysdig if I can't connect to the device? – Martin. Jan 2 '19 at 17:05
  • start sysdig to write to file. After the server hangs, reboot it and see info at the end. Maybe you can detect what is wrong. I manage several servers on Hetzner, check if ram is OK also. – titus Jan 2 '19 at 23:25
1

Since you have memtested the memory and it was good, the next step is to verify for memory leaking applications.

You might also want to check your swap configuration if you are using one.

I had similar issue and eventually it turned out that I needed to upgrade by adding more physical memory. Every time the system began using the swap it resulted in an extreme slowdown. For the record I am using a software raid.

I was lucky to be able to upgate by doubling the physical memory and convert the swap partition from RAID 1 to RAID 0.

This did not fix the issue entirely but at least provided much more time for a solution to be found latter.

Now the inevitable freeze is harder to reach as the RAID 0 about doubled the speed for the swap partition. In my case this was an acceptable solution since the system is not used as a server.

Hope this helps

  • I am having raid1. Memory for that server is 64GB so I guess it's not anything leaking. I wrote script to monitor it anyways to be sure. swapon is on /dev/md0 partrition, 32G. I hope I will find something thanks to that script logging each 5 seconds the loads and memory usage. – Martin. Jan 2 '19 at 17:08
  • Did you manage to make progress with the memory usage logging script? Keep me posted if/when you find something new. Quite curious about the whole thing! – dankilev Jan 3 '19 at 19:58
  • Yes, mem used 613MB, free 61794, load avg 0.31 is the last record. I have no idea how to continue now – Martin. Jan 7 '19 at 11:55
  • Quite shocking indeed! Could it be an option for you to ask for the server to be replaced with another one in case there is defective hardware or rent another server for a short period of time in order to migrate everything there and stop using the old one in case there might be some physical issue? Once this is done at least you could be able to somewhat reduce this as a possible cause. – dankilev Jan 7 '19 at 14:33
  • I won't accept the answer right now because I solve it properly. We'll see it then :) – Martin. Jan 7 '19 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.