0

I want to monitor a service from another machine. Both machines are connected to a VLAN. Both machines can ping and also establish connections to each other. So connectivity in general seems fine. However when I try to fetch metrics at http://10.0.0.10:9100/metrics (Prometheus) my http connection hangs. When fetching http://10.0.0.10:9100 everything works fine. I did a tcpdump on the receiving side and can see that a connection is established but then packets are retransmitted until 10.0.0.20 sends a TCP RST. I'm not sure how to continue debugging from here or what could cause this problem. enter image description here

I'm running Ubuntu 18.04 with both iptables and ufw disabled.

Edit: Seems I solved the issue by setting the MTU to 1450 instead 1500. This was mentioned in guides for private networking for other hosters. Any explanation why this solved the issue would still be great

  • Your machine, not the server dont answer to the retransmitted packet, make sure it’s not blocked anywhere – yagmoth555 Jan 1 at 16:24

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.