0

I recently changed disk on one of our servers using MegaCLI, it actually uses Dell controller with perccli utility, but it has some issues and this swap could not be done with it.

At one point, i accindetally set new disk Online before manually running rebuild, hence the disk was completly empty, no file system. After a minute alarm came in saying that whole volume is inaccessible. I set disk offline again and found out i need to run rebuild command manually (usually with perccli or mdadm the rebuild starts automatically, hence the mistake).

Collegue umnounted/mounted the volume and it seemed to help. Problem is that since then the filesystem seems corrupted and volume becomes inaccesible randomly.

The damage is done, i now wonder what could cause it, if only that misstep with setting it online (which i dont understand how). Follows my exact steps

mark offline
MegaCli -PDOffline -PhysDrv [118:30] -a1

mark missing
MegaCli -PDMarkMissing -PhysDrv [118:30] -a1

mark removal
MegaCli -PdPrpRmv -PhysDrv [118:30] -a1

find parameters of missing
megacli -Pdgetmissing -a1

Replace missing
megacli -PdReplaceMissing -PhysDrv[118:30] -Array9 -row2 -a1

Here probably mistake - setting online - with follwoing steps

Mark online
MegaCli -PDOnline -PhysDrv [118:30] -a1

mark offline
MegaCli -PDOffline -PhysDrv [118:30] -a1

Star rebuild
megacli -PDRbld -start -PhysDrv[118:30] -a1

Here are OMSA logs

Mon Dec 31 14:20:42 2018    Device returned to normal: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 14:20:41 2018    Physical disk Rebuild started: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 14:14:17 2018    Redundancy lost: Virtual Disk 2 (vod2) Controller 1 (PERC H810 Adapter)
Mon Dec 31 14:14:17 2018    Virtual disk degraded: Virtual Disk 2 (vod2) Controller 1 (PERC H810 Adapter)
Mon Dec 31 14:14:15 2018    Physical disk offline: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 14:06:59 2018    Physical disk online: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 14:05:52 2018    A physical disk that was marked as missing has been replaced.: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 14:05:51 2018    Physical disk offline: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 13:46:37 2018    Physical device inserted: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 13:31:43 2018    Physical device removed: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 13:31:43 2018    Device failed: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 13:00:54 2018    The Physical Disk Power status changed from Spun Up to Spun Down: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 12:45:48 2018    Device returned to normal: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 12:45:47 2018    A physical disk is marked as missing.: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 12:45:22 2018    Device returned to normal: Physical Disk 0:0:30 Controller 1, Connector 0
Mon Dec 31 12:45:22 2018    Physical disk offline: Physical Disk 0:0:30 Controller 1, Connector 0
  • Ad. i was told by more experienced admin that i could have just took the disk out and put new in with out any preparation, which seems lot more brutal to me and basivaly the same - disk would be set Online by default anyway, with no rebuild until started manualy – J B Jan 2 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.