0

When using AUTH, postfix adds AUTH=<> to the envelope sender. This causes a CrossBox server to reject the message:

220  CrossBox SMTP Proxify # 232 (1) Fri, 04 Jan 2019 08:13:35 +0000
EHLO example.com
250-Hello example.com[x.x.x.x]
250-PIPELINING
250-8BITMIME
250-STARTTLS
250 AUTH LOGIN PLAIN
AUTH LOGIN
[digest sent]
X.235 Authentication successful
MAIL FROM:<test@example.com> AUTH=<>
501 Was expecting MAIL arg syntax of FROM:<address>

If I telnet to the CrossBox server and omit the AUTH=<> it works OK.

The CrossBox server is outside my control. Is there a way I can adjust the postfix settings to still authenticate but prevent AUTH=<> being appended?

Currently

smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous
smtp_use_tls=no

(smtp_use_tls=no for testing purposes, so I can tcpdump the interaction)

  • Whoever is running that CrossBox is losing a lot more mail than just yours. It might not be under your control, but you should notify whoever runs it. – Michael Hampton Jan 4 at 13:04
  • Problem has now been reported back to CrossBox, but still interested if there is anything I can do on the postfix side to get it working. – tetech Jan 4 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.