0
gentoolaptop / # systemctl status cachefilesd
● cachefilesd.service - Local network file caching management daemon
   Loaded: loaded (/lib/systemd/system/cachefilesd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2019-01-04 19:01:42 CST; 4s ago
  Process: 11965 ExecStart=/sbin/cachefilesd -n -f /etc/cachefilesd.conf (code=exited, status=1/FAILURE)
  Process: 11964 ExecStartPre=/sbin/modprobe -qab cachefiles (code=exited, status=0/SUCCESS)
 Main PID: 11965 (code=exited, status=1/FAILURE)

Jan 04 19:01:42 gentoolaptop systemd[1]: Starting Local network file caching management daemon...
Jan 04 19:01:42 gentoolaptop systemd[1]: Started Local network file caching management daemon.
Jan 04 19:01:42 gentoolaptop cachefilesd[11965]: Can't confirm cache location: errno 2 (No such file or directory)
Jan 04 19:01:42 gentoolaptop systemd[1]: cachefilesd.service: Main process exited, code=exited, status=1/FAILURE
Jan 04 19:01:42 gentoolaptop systemd[1]: cachefilesd.service: Failed with result 'exit-code'.

The cache directory is set as /var/cache/fscache in cachefiles.conf:

dir /var/cache/fscache
tag mycache
brun 10%
bcull 7%
bstop 3%
frun 10%
fcull 7%
fstop 3%

# Assuming you're using SELinux with the default security policy included in
# this package
#secctx system_u:system_r:cachefiles_kernel_t:s0

If I try to create that directory, the service fails with this issue:

gentoolaptop / # systemctl status cachefilesd
● cachefilesd.service - Local network file caching management daemon
   Loaded: loaded (/lib/systemd/system/cachefilesd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2019-01-04 17:04:52 CST; 1h 51min ago
  Process: 9679 ExecStart=/sbin/cachefilesd -n -f /etc/cachefilesd.conf (code=exited, status=1/FAILURE)
  Process: 9678 ExecStartPre=/sbin/modprobe -qab cachefiles (code=exited, status=0/SUCCESS)
 Main PID: 9679 (code=exited, status=1/FAILURE)

Jan 04 17:04:52 gentoolaptop systemd[1]: Starting Local network file caching management daemon...
Jan 04 17:04:52 gentoolaptop systemd[1]: Started Local network file caching management daemon.
Jan 04 17:04:52 gentoolaptop cachefilesd[9679]: About to bind cache
Jan 04 17:04:52 gentoolaptop systemd[1]: cachefilesd.service: Main process exited, code=exited, status=1/FAILURE
Jan 04 17:04:52 gentoolaptop cachefilesd[9679]: CacheFiles bind failed: errno 105 (No buffer space available)
Jan 04 17:04:52 gentoolaptop systemd[1]: cachefilesd.service: Failed with result 'exit-code'.

chmod 777 has no effect.

dmesg:

[  924.197705] CacheFiles: mkdir cache failed with error -105
[  924.197708] CacheFiles: Failed to register: -105

fstab:

gentooserver:/  /media/store    nfs4    rw,_netdev,noauto,user,lazytime,exec,sync,tcp,vers=4.1,fsc      0 0
0

Apparently 3 gigs of free space isn't enough. You need >20.

Not the answer you're looking for? Browse other questions tagged or ask your own question.