1

THE PROBLEM:
When I browse from external Internet or on the server itself my ASP.NET web app hosted on Windows Server 2016 IIS on my new AWS EC2 VM, I get "error 403 Access is denied".

ATTEMPTS TO FIX...
IIS > Connections > my_web_site > browse doesn't work: "The webpage cannot be found"
IIS > Connections > my_web_site > Manage Website > browse cmd gets Server Error

IIS > Connections > my_web_site > Edit Bindings > browse gets Server Error

BACKGROUND...
ASP.NET works ok on previous Azure VM.

ASP.NET app runs ok when I debug it from Visual Studio on VM.

All IIS bindings set up just like on previous Azure VM.

WEB APP'S IIS PROPERTIES...………. enter image description here

2

It seems you did not put the code in folder C:\inetpub\wwwroot.
In case code is located in a folder different from this, you should give full control permission to the folder for user IIS_USRS. This is the user which IIS uses to service the content.

  • Code is located at a different path and folder than this, where it has been for about 10 years. Web app has been running on Windows server 2012 R2 for the last few years on Azure. Now I'm moving it to AWS. – Doug Null Jan 12 at 14:05
  • Does web app need to be in C:\inetpub\wwwroot\ for Windows Server 2016? it is presently in C:\PRIMARY\etcetct\ which worked OK for years on Windows Server 2012 R2. – Doug Null Jan 12 at 17:42
  • Does the folder has sufficient permissions for IIS_USR to read/write and execute the content inside code folder. – Abhishek Mishra Jan 16 at 12:00
  • I set web site's folder C:\PRIMARY\etcetc\ to full control by everyone and it still doesn't work. – Doug Null Jan 26 at 18:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.