1

I am a novice GCP user trying to run 4 scripts in parallel on an a linux instance with 4 CPUs, 4 GPUs, 15 GB RAM, and 30 GB Disk space.

However, a few minutes after initializing my scripts, both WinSCP and PuTTY disconnect me from the server and I am unable to reconnect. The instance appears to continue running on GCP website. I've tried making a new instance but the problem remains.

When I run just a single script on the instance, I have no issues.

Any idea what might be causing this? Any clues would be an enormous help, thanks!

0

It might be OOM Killer killed sshd due to heavy load of your server while running 4 script in parallel. You can monitor your VM load and check whether the time you got kicked form ssh is when the load spike.

You could try: Restart the server, reconnect and check the log whether OOM Killer kick in.

  • You were right, I just needed to increase CPUs to 4 and RAM to 30GB. Thanks! – Eric Muccino Jan 7 at 17:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.