When accessing oletymeshop.com from wifi, evrything works fine on http and https. When accessing over mobile network (4g / lte) http works, but https times out and nothing ever shows in the httpd access_log or error_log. Also effecting other sites served by apache. Sites severd by other means (node.js, python, etc) are working fine on https over mobile.
No manual changes were made to initiate this problem.

The server is currently hosting http and https, using a lets-encrypt cert on oletymeshop.com

Relevant system stats: Centos 7, Bind 9, Apache 2.4 on a dedicated server. Average system load is 1%.

Things we have tried:

  • Disabling firewall
  • Serving plain html with no javascript (hello world)
  • Disabled all ipv6 (apache and dns settings)
  • Switching to a self signed certificate
  • Tested on at&t and cricket networks
  • Tested on iOS, Android Chrome and Android Firefox
  • Rewriting configs for httpd and dns server

Any suggestions or advice would greatly appreciated.

Thanks John

Note: This was originally posted on stack overflow before realizing it was in the wrong place. No answers posted there at this time.

  • Your site doesn't have IPv6 enabled. This could cause problems for users on mobile connections, where IPv6 is the default, (not to mention any wired ISP connection with IPv6 like Comcast or Spectrum) and of course it will be slower and less reliable on IPv4 anyway. You should make sure IPv6 is enabled and that your site is accessible from a global IPv6 address. – Michael Hampton Jan 7 at 0:38
  • Thanks Michael. I was hoping it was something else. Things were running fine a couple weeks ago. The company we rent the server from says that they don't provide any ipv6 support. I'm thinking they might be using old hardware on their network. Not sure though. – Jonathan Elder Jan 7 at 1:16
  • It's 2019; not doing IPv6 is difficult to excuse now, especially for web sites where it's actually important. Almost every reputable provider of web hosting services provides IPv6 and has done for years. It may just be time to go shopping. BTW, I don't know what problem you have, but your site is working fine for me, albeit more slowly, on T-Mobile, Sprint and US Cellular... – Michael Hampton Jan 7 at 1:20
  • Thank you for checking. Been trying to find someone that could try on another network. I wasn't surprised that cricket didn't work, as they were bought by AT&T. Still not getting through over https with either of them though. Might just be an AT&T thing really. – Jonathan Elder Jan 7 at 1:28
  • Could be. I haven't got easy access to AT&T or Verizon so I didn't look on those. I do stand by my advice to get IPv6 even if you have to change providers to do it. – Michael Hampton Jan 7 at 1:30

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.