1

I'm working on an old server of mine. I'm trying to run yum update and there seems to be an issue.

So far, I've tried setting that log directory to 777 and same with the 2 log files within it.

That didn't help. Any ideas what is wrong?

# yum update
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: centos.quelquesmots.fr
 * epel: mirrors.ircam.fr
 * extras: centos.quelquesmots.fr
 * updates: centos.quelquesmots.fr
Resolving Dependencies
--> Running transaction check
---> Package httpd.x86_64 0:2.2.15-30.el6.centos will be updated
---> Package httpd.x86_64 0:2.2.15-69.el6.centos will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================================================================================================
 Package                                      Arch                                          Version                                                      Repository                                   Size
===========================================================================================================================================================================================================
Updating:
 httpd                                        x86_64                                        2.2.15-69.el6.centos                                         base                                        836 k

Transaction Summary
===========================================================================================================================================================================================================
Upgrade       1 Package(s)

Total download size: 836 k
Is this ok [y/N]: y
Downloading Packages:
httpd-2.2.15-69.el6.centos.x86_64.rpm                                                                                                                                               | 836 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : httpd-2.2.15-69.el6.centos.x86_64                                                                                                                                                       1/2 
Error unpacking rpm package httpd-2.2.15-69.el6.centos.x86_64
warning: /etc/httpd/conf/httpd.conf created as /etc/httpd/conf/httpd.conf.rpmnew
error: unpacking of archive failed on file /etc/httpd/logs: cpio: rename
httpd-2.2.15-30.el6.centos.x86_64 was supposed to be removed but is not!
  Verifying  : httpd-2.2.15-30.el6.centos.x86_64                                                                                                                                                       1/2 
  Verifying  : httpd-2.2.15-69.el6.centos.x86_64                                                                                                                                                       2/2 

Failed:
  httpd.x86_64 0:2.2.15-30.el6.centos                                                                  httpd.x86_64 0:2.2.15-69.el6.centos                                                                 

Complete!

Trying another command:

# yum install google-chrome-stable
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: centos.quelquesmots.fr
 * epel: mirrors.ircam.fr
 * extras: centos.quelquesmots.fr
 * updates: centos.quelquesmots.fr
Resolving Dependencies
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:71.0.3578.98-1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.16)(64bit) for package: google-chrome-stable-71.0.3578.98-1.x86_64
--> Processing Dependency: liberation-fonts for package: google-chrome-stable-71.0.3578.98-1.x86_64
--> Processing Dependency: libgtk-3.so.0()(64bit) for package: google-chrome-stable-71.0.3578.98-1.x86_64
--> Processing Dependency: libappindicator3.so.1()(64bit) for package: google-chrome-stable-71.0.3578.98-1.x86_64
--> Processing Dependency: libatspi.so.0()(64bit) for package: google-chrome-stable-71.0.3578.98-1.x86_64
--> Processing Dependency: libgdk-3.so.0()(64bit) for package: google-chrome-stable-71.0.3578.98-1.x86_64
--> Processing Dependency: libatk-bridge-2.0.so.0()(64bit) for package: google-chrome-stable-71.0.3578.98-1.x86_64
--> Finished Dependency Resolution
Error: Package: google-chrome-stable-71.0.3578.98-1.x86_64 (google-chrome)
           Requires: libatk-bridge-2.0.so.0()(64bit)
Error: Package: google-chrome-stable-71.0.3578.98-1.x86_64 (google-chrome)
           Requires: libgtk-3.so.0()(64bit)
Error: Package: google-chrome-stable-71.0.3578.98-1.x86_64 (google-chrome)
           Requires: libappindicator3.so.1()(64bit)
Error: Package: google-chrome-stable-71.0.3578.98-1.x86_64 (google-chrome)
           Requires: libatspi.so.0()(64bit)
Error: Package: google-chrome-stable-71.0.3578.98-1.x86_64 (google-chrome)
           Requires: libc.so.6(GLIBC_2.16)(64bit)
Error: Package: google-chrome-stable-71.0.3578.98-1.x86_64 (google-chrome)
           Requires: liberation-fonts
Error: Package: google-chrome-stable-71.0.3578.98-1.x86_64 (google-chrome)
           Requires: libgdk-3.so.0()(64bit)
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
httpd-2.2.15-30.el6.centos.x86_64 has missing requires of httpd-tools = ('0', '2.2.15', '30.el6.centos')
httpd-devel-2.2.15-69.el6.centos.x86_64 has missing requires of httpd = ('0', '2.2.15', '69.el6.centos')
6
  • You've posted two separate, unrelated problems here. That you can't install Google Chrome has absolutely nothing to do with being unable to update httpd. (It requires CentOS 7 and doesn't work at all (anymore) on 6.) Commented Jan 7, 2019 at 4:23
  • @MichaelHampton They are not unrelated. The errors both revolve around httpd updates.
    – User
    Commented Jan 7, 2019 at 5:18
  • Have you try to change by hand the repo host? FOr me it seems like problematic files in repo Commented Jan 7, 2019 at 8:34
  • Um, what? The error you got about Google Chrome is still completely unrelated to installing httpd. I don't understand why you are trying to claim that it is. Commented Jan 7, 2019 at 12:37
  • @RomeoNinov again, it’s an old server so i don’t know what i did 5 years ago
    – User
    Commented Jan 7, 2019 at 15:46

0

You must log in to answer this question.

Browse other questions tagged .