0

I'm installing this OEM API on Windows 10 under IIS 7. In the basic settings for the site, I want to set Pass-through verification to IUSR. As I understand from the Microsoft docs

This built-in account does not need a password and will be the default identity that is used when anonymous authentication is enabled.

And sure enough, in my applicationHost.config there's

<anonymousAuthentication enabled="true" userName="IUSR" />

So in IIS, in the basic settings, under Pass-through-verification I click Connect as, then turn on the radio button for Specific user, click Set..., for user name I type in IUSR, I leave the password fields empty and then click OK.

When I then test settings, Verification fails because of invalid user-references (translated from Dutch:)

the references to access the physical path are invalid. Check the references and test this setting again.

(Note: when I leave this setting on 'Application user (Pass-through-verification)', I get this warning. That's not the question.)

Yet the IUSR does have read and execute rights in the API directory.

What am I doing wrong?

  • Because the "Verification" can be a false alarm. – Lex Li Jan 7 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.