0

I am trying to bridge an interface to another one but when I execute ifup br_wan to the interface I get the error message below. It's on CentOS 7 and I have the exact same setup on another box so I'm unsure what's going wrong.

Incorrect number of arguments for command Usage: brctl addbr add bridge

ifcfg-enp0s20f0

TYPE=Ethernet
BOOTPROTO=none
NAME=enp0s20f0
DEVICE=enp0s20f0
ONBOOT=yes
stp=yes
BRIDGE=br_wan
NM_CONTROLLED=no
NETWORKING_IPV6=no # disable ipv6

ifcfg-br_wan

DEVICEE=br_wan
TYPE=Bridge
ONBOOT=yes
BOOTPROTO=dhcp
NM_CONTROLLED=no
DELAY=0
NETWORKING_IPV6=no # disable ipv6

brctl show

bridge name     bridge id               STP enabled     interfaces
br_pran         8000.0008a20d13d8       no              enp0s20f1
br_wan          8000.0008a20d13d7       no              enp0s20f0

I dont really know why ifup is calling brctl so if anyone could point me in the right direction I'd appreciate it.

  • 2
    Did you copy and paste these text files? There is an obvious typo in your file ifcfg-br_wan as posted above. – Michael Hampton Jan 7 at 17:30
1

As Michael said in the comments section you have a typo in your ifcfg-br_wan file.

Please edit the file and change the first line from DEVICEE=br0 to DEVICE=br0 and try again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.