0

I have a TPLINK Switch model T2600G-52TS, I made 3 VLANs; VLAN 1 (port 1 to 2), VLAN 10 (port 3 to 12) and VLAN 20 (port 13 to 48), I have assigned PVID for each port to desired VLAN, VLAN 1 is for management only, VLAN 10 is for public net (internet), it is connected to modem and being a DHCP relay, VLAN 20 is for local network and has DHCP server assigned to it so the computers connected to vlan 20's ports can have IP addresses automatically,

I have also set a virtual interface for each VLAN, the IPs are; 192.168.100.1 for vlan 1, 192.168.1.30 for vlan 10, 192.168.0.1 for vlan 20

each port in VLAN 10 and 20 is directly connected to one computer, except one port in vlan 10 is connected to modem/router

the problem I have is, even though every computer gets IP address automatically, and every computer can ping its vlan interface, but every computer cannot ping other computers in the same vlan, I don't know this happens,

and also, I want to add a inter-vlan routing between vlan 10 and vlan 20, please guys help me

here is the configuration file:

!T2600G-52TS
#
vlan 10
 name "PublicNetwork"
#
vlan 20
 name "LocalNetwork"
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
serial_port baud_rate 38400
#
#
system-time ntp UTC+08:00 133.100.9.2 139.78.100.163 12
no system-time dst
#
#
#
user name aderayendra privilege admin secret 5 $1$N2L3B4@>A1A7F7J1F0J0L0A6N/J:H<L='()}%
user name admin privilege admin secret 5 $1$N2L3B4@>A1A7F7J1F0J0L0A6N/J:H<L='()}%
#
#
#
#
#
service dhcp server
ip dhcp server pool "LocDHCP"
network 192.168.0.0 255.255.255.0
default-gateway 192.168.0.1
#
#
ip dhcp server pool "LocDHCP"
address 192.168.0.199 hardware-address 4c:ed:fb:6c:5e:55 hardware-type ethernet
#
#
#
#
#
#
ip route 192.168.0.0 255.255.255.0 192.168.1.30
ip route 192.168.1.0 255.255.255.0 192.168.0.1
#
#

#
#
service dhcp relay
#
#
#
#
#
#
interface vlan 1
  ip address 192.168.100.1 255.255.255.0
  description "ConfigGateway"
  ipv6 enable
#
interface vlan 10
  ip address 192.168.1.30 255.255.255.0
  description "PublicGateway"
  no ipv6 enable
  ip helper-address 192.168.1.1
#
interface vlan 20
  ip address 192.168.0.1 255.255.255.0
  description "LocalGateway"
  no ipv6 enable
#
interface gigabitEthernet 1/0/1

#
interface gigabitEthernet 1/0/2

#
interface gigabitEthernet 1/0/3
  switchport general allowed vlan 10 untagged
  switchport pvid 10
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/4
  switchport general allowed vlan 10 untagged
  switchport pvid 10
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/5
  switchport general allowed vlan 10 untagged
  switchport pvid 10
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/6
  description "PublicGateway"
  switchport general allowed vlan 10 untagged
  switchport pvid 10
  no switchport general allowed vlan 1

  no ip igmp snooping
  no ipv6 mld snooping
#
interface gigabitEthernet 1/0/7
  switchport general allowed vlan 10 untagged
  switchport pvid 10
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/8
  switchport general allowed vlan 10 untagged
  switchport pvid 10
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/9
  switchport general allowed vlan 10 untagged
  switchport pvid 10
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/10
  switchport general allowed vlan 10 untagged
  switchport pvid 10
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/11
  switchport general allowed vlan 10 untagged
  switchport pvid 10
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/12
  switchport general allowed vlan 10 untagged
  switchport pvid 10
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/13
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/14
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/15
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/16
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/17
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/18
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/19
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/20
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/21
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/22
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/23
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/24
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/25
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/26
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/27
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/28
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/29
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/30
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/31
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/32
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/33
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/34
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/35
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/36
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/37
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/38
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/39
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/40
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/41
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/42
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/43
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/44
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/45
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/46
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/47
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/48
  switchport general allowed vlan 20 untagged
  switchport pvid 20
  no switchport general allowed vlan 1

#
interface gigabitEthernet 1/0/49

#
interface gigabitEthernet 1/0/50

#
interface gigabitEthernet 1/0/51

#
interface gigabitEthernet 1/0/52

#
end

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.