0

First of all I would like to say that I am a complete beginner in this topic.

I have been trying for several hours to allow my system to connect to my VPN (I have a raspberry pi with the basic configuration of OpenVPN) without leaking my IPv6 but I haven't found a way.

I can connect to my server normally and using https://ipleak.net/ for instance I can see that I have the ip of the remote server but the Ipv6 still remains the same as when not using OpenVPN.

I have tried to disable IPv6 with "sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1" but then for some reason I cannot connect to internet when I use OpenVPN (nonetheless the local network works).

However, in my android phone with the OpenVPN app I can connect to internet with no IPv6 leakage and even I can be sure to block it through its settings.

Is there any option to block IPv6 from the client as in the Android app?

I put a bit more info of my configuration:

In the client.ovpn

client
dev tun
proto udp
remote #"MY_IP_AND_PORT"
resolv-retry infinite
nobind
user nobody
group nogroup
persist-key
persist-tun
ns-cert-type server
comp-lzo
verb 3

In the server.conf

port ######
proto udp
dev tun
ca ca.crt
cert server.crt
key server.key  # This file should be kept secret
dh dh2048.pem
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "route 192.168.1.0 255.255.255.0"
push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS ###.##.###.###"
push "dhcp-option DNS ###.##.###.###"
keepalive 10 120
comp-lzo
user nobody
group nogroup
persist-key
persist-tun
status openvpn-status.log
verb 3
sndbuf 393216
rcvbuf 393216
push "sndbuf 393216"
push "rcvbuf 393216"

Thanks in advance.

migrated from security.stackexchange.com Jan 8 at 9:58

This question came from our site for information security professionals.

  • Thank you very much, your comment really helped me to find what was missing, I finally added something like this to my server.conf and everything works perfectly: server-ipv6 2001:0db8:ee00:abcd::/64 tun-ipv6 push tun-ipv6 ifconfig-ipv6 ############# push "route-ipv6 ##############" push "route-ipv6 #############" – J. Polo Jan 6 at 17:21
0

Your server is not providing any IPv6 addresses to its clients. You need to fix that using an appropriate server-ipv6 directive.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.