0

I'm trying to get a disposable virtual machine on my private server.

I've tried downloading a couple of Debian ISO files for 9.6.0, but I am unsuccessful in booting any of them.

After trying kvm -m 2048 -smp 2 -hda debian.12GB.img -cdrom debian-9.6.0-amd64-DVD-1.iso -boot d -curses, and same with debian-live-9.6.0-amd64-xfce.iso, all I get is the following, and it doesn't progress anywhere further:

640 x 480 Graphic mode.

I've tried the -nographic option as well, but it didn't seem to result in anything being printed at all.

0

The curses UI can only show something as long as the guest runs in vga text mode. The "640 x 480 Graphic mode" message indicates the guest switched to graphics mode. Probably the cdrom boot loader (isolinux) did that and is waiting for input now.

Try use vnc or gtk for the install. Once the install is complete you can configure the guest to use vga text mode, then curses should work fine too.

  • Are you seriously telling me that it's not possible to install Linux in curses? There's gotta be a better way. I've been installing OSes in text mode for years (FreeBSD, OpenBSD, you name it); I'm not open about having to switch to VNC et al for having to simply do an install, especially in the server environment and of a KVM-based installation, which has very little reason to not work over serial in the first place. – cnst Jan 9 at 6:07
  • vnc is easiest. If you know how to navigate the debian cdrom boot menu you can try typing blindly. – Gerd Hoffmann Jan 9 at 6:11
  • I don't think I've ever had to install Debian before. Does it seriously not have a text-based installer?! Which distros do? – cnst Jan 9 at 6:13
  • debian installer runs just fine in text mode, you only need to make sure the linux kernel boots in text mode ("vga=0 nomodeset" on the command line). As mentioned it is the cdrom boot loader which switched to gfx mode. You can also loop-mount the cdrom, copy kernel + initrd to the host, then use direct kernel boot. isolinux doesn't get into the way then. When going this route I'd suggest to add "console=ttyS0" to the kernel command line and use -nographic (qemu stdio gets linked to the guests serial line then). – Gerd Hoffmann Jan 9 at 6:35
  • I think the <key>ESC</key> button works, and brings some text prompt, but i have no idea what that prompt is about. i've tried typing stuff on it, but it didn't really go anywhere. i really don't understand why there's a need to do VGA; why is there nothing that gets printed to serial? DragonFly BSD, for example, prints to both VGA and serial. – cnst Jan 9 at 18:19

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.