1

Immediately after login into EAC/ECP I'm presented with 503 error. However, simply refreshing the page brings up EAC as expected and it works fine after that. Until I log out and attempt to log in again after a while, the story repeats itself.

Even ID 1003 from MSExchange Front End HTTP Proxy and 1309 from ASP.NET 4

I tried using both the self-gen and a CA issued cert on the back-end site, makes no difference. Just did that to cover bases others were on but I didn't think this would be it since it's such a temporary issue, simply refreshing the page brings it up, which a cert problem would not present.

Similarly, opening the EMS on the server initially throws up pages of red errors but when closed and opened again, it start fine.

So something seems to be pausing/stopping and needs a few seconds to start back up.

1

1.How many Exchange servers are in your environment?

2.If you access EAC with 'localhost' or IP address, does the 503 error reoccur?

3.Could you provide a screenshot of EMS red error?

As you can log in EAC again successfully, I consider the issue may occur by SharedWebConfig.config files in ExchangeInstallPath get corrupted. You could do the following steps:

1.On the affected Exchange 2016 server got to C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy and rename the file SharedWebConfig.config to SharedWebConfig.config_OLD

2.On the affected Exchange 2016 server got to C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess and rename the file SharedWebConfig.config to SharedWebConfig.config_OLD

3.Open EMS, run cd %ExchangeInstallPath%\bin to change the current directory to the bin folder that's under the Exchange installation path. 3-1.Run the following command:

DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\ClientAccess" -configFile "%ExchangeInstallPath%\ClientAccess\SharedWebConfig.config"

3-2.Run the following command:

DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\FrontEnd\HttpProxy" -configFile "%ExchangeInstallPath%\FrontEnd\HttpProxy\SharedWebConfig.config"

4.Run IISRESET, or restart the server.

If the issue persists, disable Antivirus or firewall add-ins and check again.

Update your Exchange server version to the latest.

2
  • Thanks for the lengthy response, Kelvin. 1) Only one 2) Yes, it does 3) This is the 'red' error dumped when I first open EMS. This only happens one time. If I close it and open again, it opens without any issues. The dump is very long so instead of a screenshot, here is the whole text copy&pasted: justpaste.it/2pk89 4) I ran the DependentAssemblyGenerator commands and rebooted but this did not resolve the issue. 5) There is no third party AV on this server and local firewall is turned off – prl77 Jan 16 '19 at 21:41
  • Could you try to check and run Windows update on your Exchange server? I suspect that exceptions are occurred in your Exchange server, but I can't point out details, sorry.. – Kelvin_D Jan 17 '19 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.