0

I've manually tried adding and removing some entries in /etc/valiases/<domain> files in the system as root to configure mail forwarding but unfortunately, some forwarding which I manually removed and added are not taking effect. It looks like a cache or certain copy of the old forwarders still exist. I restarted all services and even cleared exim cache but still not luck.

I bumped into a solution about recreating the /etc/aliases.db but I am not sure if exim is using this file. I've also tried the ff commands but no luck:

exim_dbmbuild /etc/aliases /etc/aliases.db

or

exim_dbmbuild /etc/valiases/<domain> /etc/aliases.db

Some guys from the forums mentioned that we have to run newaliases command as root in the terminal to rebuild /etc/aliases.db but it looks like this is for Sendmail MTP and not for exim. Anyone can help me understand how to update mail forwarders?

Btw, I've also used the CPANEL interface for this but it looks like the same thing is happening

New contributor
philxtian is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • You need to add a lot more detail about your setup, as I've been using exim since day 1 and I've never encountered /etc/valiases/ directories, which means that this is specific to some non-standard configuration you're using. – wurtel Jan 10 at 8:58

Your Answer

philxtian is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.