0

Am new to serverfault, hoping to see the experts answers for my query.

I have done a Active/passive setup for 1 cell vCloud Director. Below are the setup details.

  • OS : CentOS 7.10
  • vCloud Director : 9.5
  • DRBD9.0 : For data replication between 2 nodes
  • Corosync & Pacemaker : For heartbeat and resource creation.

Below is the cluster details : After creating resource VCD-SERVICE for service vmware-vcd, am getting below failed action and cluster goes into no responsive mode even if i restart pacemaker.

Resource created with this command:

pcs resource create VCD-SERVICE lsb:vmware-vcd op monitor interval=15s

Experts valuable input is highly appreciated & thanks in advance.

# pcs status
Cluster name: VCD_Cluster
Stack: corosync
Current DC: app1 (version 1.1.19-8.el7_6.2-c3c624ea3d) - partition with quorum
Last updated: Wed Jan  9 07:11:40 2019
Last change: Wed Jan  9 06:52:26 2019 by root via cibadmin on app2

2 nodes configured
5 resources configured

Online: [ app1 ]
OFFLINE: [ app2 ]

Full list of resources:

 VCD_VIP        (ocf::heartbeat:IPaddr2):       Started app1
 Master/Slave Set: VCDClone [VCD-DRBD]
     Masters: [ app1 ]
     Stopped: [ app2 ]
 VCD_FS (ocf::heartbeat:Filesystem):    Started app1
 VCD-SERVICE    (lsb:vmware-vcd):        ORPHANED FAILED app2 (blocked)

Failed Actions:
* VCD-SERVICE_monitor_0 on app1 'not installed' (5): call=18, status=Not installed, exitreason='',
    last-rc-change='Wed Jan  9 07:09:33 2019', queued=1ms, exec=1ms
* VCD-SERVICE_stop_0 on app2 'not configured' (6): call=21, status=complete, exitreason='',
    last-rc-change='Wed Jan  9 07:14:32 2019', queued=0ms, exec=28ms


Daemon Status:
  corosync: active/enabled
  pacemaker: active/enabled
  pcsd: active/enabled

Refer image for VCD-SERVICE detailsenter image description here

1 Answer 1

0

I believe you want to define the VCD-SERVICE with the systemd class instead of lsb.

LSB init scripts must be located in /etc/init.d, and must comply with LSB exit codes to be used with Pacemaker. In CentOS 7, most services are controlled by systemd.

EDIT 1: Here is a link to LSB spec: http://refspecs.linuxbase.org/LSB_3.0.0/LSB-PDA/LSB-PDA/iniscrptact.html

and another link to the Linux-HA.org wiki to check for compliance: http://www.linux-ha.org/wiki/LSB_Resource_Agents

It's usually pretty easy to edit an init script to make it LSB compliant, but you can also write an OCF resource agent for Pacemaker. A quick Google for, "OCF Pacemaker resource agent development" should bring up some good resources.

1
  • Dear Matt, thank you for your input, yes i have tried using systemd class but pacemaker is not identifying that as service, do you know how to create the resource for service using pcs. Jan 12, 2019 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.