1

I have a Server 2016 (not using WSUS) that is simply refusing to download updates.

I've deleted the softwaredistribution folder multiple times and nothing has helped.

At one point it briefly showed me the available updates it was going to download before going straight to the "Download updates 0%" message again, where it has been sitting for hours.

I've tried everything I could think of but nothing helps. Sadly there isn't a WU troubleshooter for Server 2016 like there is for Windows 10.

Any thoughts/scripts anyone may have?

There are no errors at all, it just doesn't download anything and just sits there...

It recreates the softwaredistribution folder every time to about 503 MB then does nothing. It has enough space, so that's not the issue either.

Thanks.

  • Is this a new install of Windows 2016, i.e., one that hasn't had any of the cumulative updates successfully installed yet? If so, you may need to download and manually install one of the cumulative updates in order to get Windows Update working properly. I suggest you download the December 2018 cumulative update, that way there is still this month's update waiting to be done so you can see whether the problem has been fixed or not. – Harry Johnston Jan 11 at 0:55
  • Hi everyone. No AV present. It is an old install of 2016, hasn't had updates in a long time. I did think I may end up having to manually download updates, which I hate doing... I will give that a go and see what happens, thanks... – user757392 Jan 11 at 9:59
2

It turns out that the Windows Firewall was completely disabled on this VM...

The moment I turned it back on updates started downloading again.

Thanks for trying to help everyone.

0

Have you tried:

net stop "Windows Update" & net start "Windows Update" to restart the Windows Update service.

Also check that you can ping -l 1 -n 1 download.windowsupdate.com.

  • Hi there. Of course I tried to restart the service, it has not helped. I can ping that as well and do get a reply, still makes no difference. – user757392 Jan 11 at 9:59
  • There might be a log, open Event Viewer with Administrative privileges then look for Applications and Services Logs -> Microsoft -> Windows -> WindowsUpdateClient. If you click on "Level" twice, then you can alphabetically filter out what level the log is, looking at Error logs could be useful. Then feel free to post the error code on here. – Bean6754 Jan 11 at 13:53
  • Well, I used wsus offline for now and it did install the updates which was great. There is an error event ID 31 in the logs though. Failure to download is all it says though... – user757392 Jan 11 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.