0

When I try to run yum update it says libmemcached-opt-libs requires libevent2 but I couldn't find how to install libevent2. When I try yum install libevent2 I get No package libevent2 available message.

Does Anyone has similiar issue on libmemcache update ?

[root@XXXX ec2-user]# yum update
Loaded plugins: priorities, update-motd, upgrade-helper
1404 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php72-php-pecl-memcached.x86_64 0:3.0.4-1.el6.remi will be updated
---> Package php72-php-pecl-memcached.x86_64 0:3.1.3-1.el6.remi will be an update
--> Processing Dependency: libmemcached-opt-libs(x86-64) for package: php72-php-pecl-memcached-3.1.3-1.el6.remi.x86_64
---> Package php72-php-pecl-msgpack.x86_64 0:2.0.2-4.el6.remi will be updated
---> Package php72-php-pecl-msgpack.x86_64 0:2.0.3-1.el6.remi will be an update
--> Running transaction check
---> Package libmemcached-opt-libs.x86_64 0:1.0.18-1.el6.remi will be installed
--> Processing Dependency: libevent2(x86-64) for package: libmemcached-opt-libs-1.0.18-1.el6.remi.x86_64
--> Finished Dependency Resolution
Error: Package: libmemcached-opt-libs-1.0.18-1.el6.remi.x86_64 (remi)
           Requires: libevent2(x86-64)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
  • Look at the package exclusions you have put in place. – Michael Hampton Jan 10 at 19:13
  • @MichaelHampton Thanks for the comment. I tried yum --enablerepo=* search libevent2 as well. Also I changed repos priorities. But I still get Warning: No matches found for: libevent2 message. Is there anything that I can do to install libevent2 package ? – freedom_mine Jan 10 at 19:50
  • Get rid of the package exclusions. – Michael Hampton Jan 10 at 21:04
  • Reported upstream in forum.remirepo.net/viewtopic.php?id=3789 and fixed – Remi Collet Jan 11 at 8:12
0

This issue doesn't exists on CentOS 6, only on Amzn altered distribution, which provides libevent version 2 instead of libevent version 1 + libevent2 for version 2

The new build of libmemcached-opt-libs (version 1.0.18-2) improve dependencies handling, and fix this issue.

  • Thank you so much for the quick fix. Now yum update works correctly. – freedom_mine Jan 14 at 9:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.