1

I am running 2 domain controllers and the DC1 will not replicate GPOs to DC2. Upon looking in the logs the DFSR on DC2 is not showing Event 4604 which is the succssfull copy of SYSVOL of DC1. If I look for events on DC1 I find these 2 errors.

Event 2212

The DFS Replication service has detected an unexpected shutdown on Volume (drive):. This can occur if the service terminated abnormally (due to a power loss, for example) or an error occurred on the volume. The service has automatically initiated a recovery process. The service will rebuild the database if it determines it cannot reliably recover. No user action is required.

Additional Information:

Volume: (driveguid)

And

Event 2004 The DFS Replication service stopped replication on the volume . This failure can occur because the disk is full, the drive is failing, or a quota limit has been reached. This can also occur if the DFS Replication service encountered errors while attempting to stage files for a replicated folder on this volume.

Additional information:

Error: 5 (Access is denied)

Volume: (driveguid)

All my computers are now connected to DC2 for GPO changes and not DC1 which has the latest and greatest versions of the GPOs. DC2 is also using itself to get GPOs.

Now I have checked the drive security permissions and they remain at the default settings. I have tried to do a D2 forces of DFSR sysvol but it only ended up with a 4614 event that there is a pending copy of sysvol coming. It never go to a 4604 event saying it completed.

As far as the 2212 event is concerned I am not sure how that error is happening since it is a raided partition on a raid array across 6 drives.

Can anyone help me out with how to do this before I have to demote and repromote both domain controllers so I can get the policies to replicate again?

UPDATE 1: When trying to do a replication propagation test from DC1 to DC2 it says that when it tries to create the propagation test file on the DC2 SYSVOL it can't be created because access is denied.

0

Tried a D2 rebuild of the non-authoritative Domain Controller and DC1 could still not copy a propagation test to DC2. Did a DCPROMO of both DCs and was able to propagate back and forth. On promotion of DC1 moved the SYSVOL back from the E partition to the C partition and the 2212 errors stopped.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.