0

Need help here...

Running Windows Server Essentials 2016 and added an IIS website.

When accessing the site from anywhere on our internal subnet 192.168.1.x, the site returns the proper page. Even from a phone connected to WiFi on the same subnet, it returns the page.

External traffic does not return anything, it just times out. Tested from an external computer that gets a time out and from switching the phone to 4g to force it to come through the internet.

Looking in the IIS log files, the requests from outside the company subnet are not seeming to make it to the server.

We migrated from a different physical server so I know the router is passing the traffic (and the internal network traffic is working).

Any thoughts on where to look?

I have added rules to allow it to pass inbound and outbound tcp and udp on port 80, totally disabled the firewall and even added admin level permissions to the IISuser profile (since turned them all back off after testing).

3
  • We migrated from a different physical server so I know the router is passing the traffic - How do you know that? Have you actually verified that the network router/firewall is configured correctly? Because this sure sounds like a network router/firewall issue. – joeqwerty Jan 10 '19 at 23:42
  • The router was pointing to a different server that was working properly. All references in the router where changed to the new ip address of the new server. And for good measure, I rebooted the router too. I then switched the router to point to the old server and it worked fine. Switched it back and it does not get through. – S Marino Jan 11 '19 at 19:09
  • SOLVED -- posting this in the hope that it helps someone else - since I didn't find it. The physical server has 2 ethernet ports, one for internal traffic and one for external. I made the incorrect assumption to assign the ip address of the external port to the website in the bindings and to forward the traffic in the router to the external port. Switching it to the internal port in the bindings and forwarding the port 80 traffic to the internal ip port fixed the issue. – S Marino Jan 12 '19 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.