1

I'm having issues with the Couchbase resources especially RAM, I know that Couchbase is too aggressive with the CPU usage but I thought that by setting some memory quota for each service is enough so Couchbase don't eat all my memory

Right now I have a bucket with about 4.1M of records, the server node have enabled the services data, index, query and search

I have single bucket, about 25 indexes and have 2 searches

I have the following quotas for each service

  • Data 4096MB
  • Index 2048MB
  • Search 2048MB
  • Analytics 1024MB
  • Eventing 256MB

the total is less than 10GB of ram, but if I do a rebuild of the indexes is take more of than, exhaust the full memory of my machine, no matter how much memory put on it. 16, 24, 32

My question is, how force to Couchbase to just take what I have defined for

and also some recommendation about the quotas for each service

Right now this problem is more visible when I'm restoring a backup because at that moment couch will rebuilding all indexes

  • How many nodes are in your cluster? – Matthew Groves Jan 15 at 16:06
  • 1
    only one server node – rkmax Jan 15 at 17:23
  • What indexes are you using? – Matthew Groves Jan 15 at 21:40
  • I'm using global indexes (based on settings something called Standard Global Secondary), I have partition on my indexes (WHERE clause) in order to optimize the indexes. my indexes are for different queries of the business of the app, without them Couchbase is so slow like a the turtle of the hell – rkmax Jan 15 at 22:00
0

Have you tried limiting The Couchbase server RAM quota which specifies the maximum amount of RAM to be used by the data service for caching documents?

  • please read my question, that is what I want to know, I set quotas but Couchbase don't respect them – rkmax Jan 25 at 1:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.