1

I just tried to set up a mail server on my Ubutnu 14.04. The goal is to be able to send mails from info@mydomain.com and receive mails sent to the same adress.

Now I followed this tutorial to install Postfix, Dovecot and SquirrelMail. I followed the tutorial and everything worked fine. Additionally, I added my info-user to the mail-group and as well, I set an MX-Record from @ to @, so as host, everything is sent to my domain. I found this as one problem of somebody else, which fixed it for him.. For me, it doesn't change anything though.

Now the web-part of SquirrelMail works fine, I can click everywhere and compose mails. Sent mails also are in the SENT-Folder.

However, I do neither receive mails on SquirrelMail, nor do I receive mails on mail accounts, where I tried to send mails from SquirrelMail. I tried 1and1, web.de and gmail... All with no results...

I checked the var/log/mail.err with no result.

But: in mail.log, there are some interesting lines, I'm just gonna paste them in here:

Jan 13 11:23:17 myhostname postfix/smtpd[22086]: connect from mail-vs1-f67.google.com[209.85.217.67]
Jan 13 11:23:18 myhostname postfix/smtpd[22086]: NOQUEUE: reject: RCPT from mail-vs1-f67.google.com[209.85.217.67]: 454 4.7.1 <info@chatxpress.com>: Relay access denied; from=<myadress@googlemail.com> to=<info@chatxpress.com> proto=ESMTP helo=<mail-vs1-f67.google.com>
Jan 13 11:23:18 myhostname postfix/smtpd[22086]: disconnect from mail-vs1-f67.google.com[209.85.217.67] ehlo=2 starttls=1 mail=1 rcpt=0/1 data=0/1 quit=1 commands=5/7
Jan 13 11:25:16 myhostname dovecot: imap-login: Login: user=<info>, method=PLAIN, rip=::1, lip=::1, mpid=22170, secured, session=<WECcX1l/DM8AAAAAAAAAAAAAAAAAAAAB>
Jan 13 11:25:16 myhostname dovecot: imap(info): Logged out in=117 out=1526
Jan 13 11:25:17 myhostname dovecot: imap-login: Login: user=<info>, method=PLAIN, rip=::1, lip=::1, mpid=22172, secured, session=<tz2mX1l/Ks8AAAAAAAAAAAAAAAAAAAAB>
Jan 13 11:25:17 myhostname dovecot: imap(info): Logged out in=309 out=3198
Jan 13 11:25:17 myhostname dovecot: imap-login: Login: user=<info>, method=PLAIN, rip=::1, lip=::1, mpid=22174, secured, session=<q6OxX1l/Ts8AAAAAAAAAAAAAAAAAAAAB>
Jan 13 11:25:17 myhostname dovecot: imap(info): Logged out in=117 out=1526
Jan 13 11:25:32 myhostname postfix/smtpd[22175]: connect from localhost[::1]
Jan 13 11:25:32 myhostname postfix/smtpd[22175]: A1DE045E87E0: client=localhost[::1]
Jan 13 11:25:32 myhostname postfix/cleanup[22178]: A1DE045E87E0: message-id=<f1a2b6e6d7fa2c11f2a8e1c7ac98606b.squirrel@chatxpress.com>
Jan 13 11:25:32 myhostname postfix/qmgr[15683]: A1DE045E87E0: from=<info@chatXpress.com>, size=716, nrcpt=1 (queue active)
Jan 13 11:25:32 myhostname postfix/smtpd[22175]: disconnect from localhost[::1] ehlo=1 mail=1 rcpt=1 data=1 quit=1 commands=5
Jan 13 11:25:32 myhostname dovecot: imap-login: Login: user=<info>, method=PLAIN, rip=::1, lip=::1, mpid=22181, secured, session=<uTGVYFl/jtEAAAAAAAAAAAAAAAAAAAAB>
Jan 13 11:25:32 myhostname postfix/smtp[22179]: A1DE045E87E0: host mx01.emig.kundenserver.de[217.72.192.66] refused to talk to me: 554-kundenserver.de (mxeue112) Nemesis ESMTP Service not available 554-No SMTP service 554-Bad DNS PTR resource record. 554 For explanation visit https://www.ionos.com/help/index.php?id=2425&ip=85.93.24.159&c=rdns
Jan 13 11:25:32 myhostname dovecot: imap(info): Logged out in=606 out=574
Jan 13 11:25:32 myhostname postfix/smtp[22179]: A1DE045E87E0: to=<myadress-f@online.de>, relay=mx00.emig.kundenserver.de[212.227.15.40]:25, delay=0.16, delays=0.05/0.07/0.04/0, dsn=4.0.0, status=deferred (host mx00.emig.kundenserver.de[212.227.15.40] refused to talk to me: 554-kundenserver.de (mxeue009) Nemesis ESMTP Service not available 554-No SMTP service 554-Bad DNS PTR resource record. 554 For explanation visit https://www.ionos.com/help/index.php?id=2425&ip=85.93.24.159&c=rdns)
Jan 13 11:25:32 myhostname dovecot: imap-login: Login: user=<info>, method=PLAIN, rip=::1, lip=::1, mpid=22184, secured, session=<eeqWYFl/sNEAAAAAAAAAAAAAAAAAAAAB>
Jan 13 11:25:32 myhostname dovecot: imap(info): Logged out in=117 out=1526
Jan 13 11:26:22 myhostname postfix/smtpd[22175]: connect from mx1.validemail.com[208.101.20.91]
Jan 13 11:26:22 myhostname postfix/smtpd[22175]: NOQUEUE: reject: RCPT from mx1.validemail.com[208.101.20.91]: 454 4.7.1 <info@chatxpress.com>: Relay access denied; from=<> to=<info@chatxpress.com> proto=ESMTP helo=<mx1.validemail.com>
Jan 13 11:26:22 myhostname postfix/smtpd[22175]: disconnect from mx1.validemail.com[208.101.20.91] ehlo=1 mail=1 rcpt=0/1 rset=1 quit=1 commands=4/5
Jan 13 11:26:23 myhostname postfix/smtpd[22175]: connect from mx1.validemail.com[208.101.20.91]
Jan 13 11:26:23 myhostname postfix/smtpd[22175]: NOQUEUE: reject: RCPT from mx1.validemail.com[208.101.20.91]: 454 4.7.1 <info@chatxpress.com>: Relay access denied; from=<> to=<info@chatxpress.com> proto=ESMTP helo=<mx1.validemail.com>
Jan 13 11:26:24 myhostname postfix/smtpd[22175]: disconnect from mx1.validemail.com[208.101.20.91] ehlo=1 mail=1 rcpt=0/1 rset=1 quit=1 commands=4/5
Jan 13 11:27:44 myhostname dovecot: imap-login: Login: user=<info>, method=PLAIN, rip=::1, lip=::1, mpid=22219, secured, session=<nHZvaFl/7uYAAAAAAAAAAAAAAAAAAAAB>
Jan 13 11:27:44 myhostname dovecot: imap(info): Logged out in=117 out=1526
Jan 13 11:27:47 myhostname postfix/smtpd[22175]: connect from unknown[190.85.234.7]
Jan 13 11:27:47 myhostname postfix/smtpd[22175]: disconnect from unknown[190.85.234.7] helo=1 auth=0/1 quit=1 commands=2/3
Jan 13 11:27:51 myhostname  postfix/qmgr[15683]: CB8D545E87CF: from=<info@chatXpress.com>, size=714, nrcpt=1 (queue active)
Jan 13 11:27:51 myhostname postfix/smtp[22220]: CB8D545E87CF: host mx-ha03.web.de[212.227.15.17] refused to talk to me: 554-web.de (mxweb012) Nemesis ESMTP Service not available 554-No SMTP service 554-Bad DNS PTR resource record. 554 For explanation visit http://postmaster.web.de/error-messages?ip=85.93.24.159&c=rdns
Jan 13 11:27:52 myhostname postfix/smtp[22220]: CB8D545E87CF: to=<myadress@web.de>, relay=mx-ha02.web.de[212.227.17.8]:25, delay=427, delays=427/0.03/0.06/0, dsn=4.0.0, status=deferred (host mx-ha02.web.de[212.227.17.8] refused to talk to me: 554-web.de (mxweb112) Nemesis ESMTP Service not available 554-No SMTP service 554-Bad DNS PTR resource record. 554 For explanation visit http://postmaster.web.de/error-messages?ip=85.93.24.159&c=rdns)
Jan 13 11:27:54 myhostname dovecot: imap-login: Login: user=<info>, method=PLAIN, rip=::1, lip=::1, mpid=22224, secured, session=<sMsAaVl/fugAAAAAAAAAAAAAAAAAAAAB>
Jan 13 11:27:54 myhostname dovecot: imap(info): Logged out in=85 out=789

Note that I replaced the real adresses with pseudo-adresses.

To be honest, I don't really know about the errors, but I think messages like NOQUE: reject, Relay access denied or status=deferred (host mx-ha02.web.de[212.227.17.8] refused to talk to me: don't look really good.

Does anybody have an idea on what I'm missing or what I should fix?

You can check my settings for the domain chatXpress.com as well, for info@chatxpress.com, the Domain Dossier from centralops returns

[Resolving chatxpress.com...]
[Contacting chatxpress.com [85.93.24.159]...]
[Connected]
220 localhost.localdomain ESMTP Postfix (Ubuntu)
EHLO mx1.validemail.com
250-localhost.localdomain
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
MAIL FROM:<>
250 2.1.0 Ok
RCPT TO:<info@chatxpress.com>
454 4.7.1 <info@chatxpress.com>: Relay access denied
[Unfavorable reply code, cannot continue]
RSET
250 2.0.0 Ok
QUIT
221 2.0.0 Bye
[Connection closed]

Again Replay Access Denied...

Thanks for any help!

2

You have (at least) two distinct issues here:

First, you can't receive mail with the error Relay access denied. This means that Postfix is not configured to receive mail for your domain name.

To fix the problem you will need to reconfigure Postfix, e.g. with dpkg-reconfigure postfix and give it the correct domain name. It appears that Postfix was set up with the name localhost.localdomain instead of chatxpress.com.

Second, you can't send mail because, according to the error messages you received, your host's IP address does not have a PTR record. I was able to confirm this:

$ host 85.93.24.159
Host 159.24.93.85.in-addr.arpa. not found: 3(NXDOMAIN)

The PTR record must be set by the owner of the IP address, that is, the datacenter hosting your server. Contact them for further information on how to set your PTR record.

  • Thank you for the answer! I just contacted my hosting provider regarding the PTR-record. Regarding receiving mails, I tried to reconfigure it, but I still can't receive any mails. But there were many points to configure..I used "Internet Site", "chatxpress.com" as System Mail name, "info" for root and postmaster mail recipent, and for "Other desitnations to accept mail for", I just left the list, as is it (so myhostname, localdomain, localhost, localhost.localdomain, localhost)..Then i pressed no regadring synchronous updates on mail queue ---> the rest in the next comment – nameless Jan 13 at 17:13
  • for postfix configuration on local networks, I also left it, as it is, so: 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128... I pressed no to not use procmail for local delivery, used 0 to have no mailbox size limit and chose to use all internet protocols (ipv4 and ipv6) are there any prolems in the configuration...? – nameless Jan 13 at 17:15
  • Okay, I got it fixed! somehow the dpkg-reconfigure didn't work properly, but manually setting the hostname in etc/postfix/main.cf seems to have worked! – nameless Jan 13 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.