11

I've configured systemd timesyncd to get it's time from a NTP server:

/etc/systemd/timesyncd.conf > NTP=ca.pool.ntp.org
systemctl restart systemd-timesyncd.service 
timedatectl set-ntp true

The status is the following:

$ timedatectl status
...
Network time on: yes
NTP synchronized: no

As the output implies, the time is not synced, yet. Can someone please help me out with the following questions?

  • How long will it take for timesyncd to sync with the NTP? At what intervals does it do that, where can I check and alter them?
  • In urgent cases: Can I only set the time manually or can I force timesyncd to sync immediately with the NTP server?
8

To use an actual NTP implementation, you need to install and configure one, chrony or maybe ntpd. Do so if you require any monitoring of time performance. I will assume chrony.

Add iburst to your pool or server lines in your config to speed up the initial few packets. It still may take a couple minutes to stabilize, be patient.

chronyc tracking will show the current offset. Have an idea of what your requirements are, one second accuracy can easily tolerate tens of milliseconds offset.

chronyc makestep will make the current adjustment immediately. Not necessary usually.


timesyncd is an SNTP client that can set the time, but not discipline it gradually and continuously, nor filter remote NTP server based on quality. (It also cannot talk to time hardware or PTP, only NTP protocol.) A little better than repeated ntpdate, by which I mean not very good clock. Personally, I replace it on most servers.

About the only way to set the time with timesyncd is manually: timedatectl set-time "2019-01-15 00:40:16". It does not have robust means to discipline and monitor the clock. Basic NTP stats via timedatectl timesync-status are a relatively new thing, I don't think that option is available in Red Hat 7 or Ubuntu 18.04.

systemd defines "syncronized" to be if NTP was ever used to tell Linux to adjust the clock. Specifically, if kernel discipline call adjtimex() returned without error, and not the initial state. See the source code, systemd/src/basic/time-util.c.

  • Thanks for your answer, John. So in fact I can disable systemd-timesyncd and use chrony only? I’m not quite sure I understand why systemd has a NTP option and is called timeSYNCd if it is not able to sync the time actually? “systemd defines "syncronized" to be if the NTP kernel discipline call adjtimex() returned without error, and not the initial state” - this is not very clear to me. – chevallier Jan 15 at 9:26
  • 1
    @chevallier systemd-timesyncd is very simple, and it's good enough for the most common cases, e.g. a server with a real time clock which is expected to be running and on the network 24x7. Yours is not a common case, so you should probably not use it. chrony is much better at dealing with interruptions of network connectivity and being shut down for extended periods (e.g. a laptop) or not having a RTC at all (e.g. embedded devices). – Michael Hampton Jan 15 at 15:46
  • 1
    timesyncd is a SNTP client, so it sets the time without disciplining it properly. Which is fine for coarse accuracy requirements. If you want to measure time performance, or wait until synced, use a full NTP like chrony or ntpd. – John Mahowald Jan 15 at 16:48
5

Without installing any more packages... Turn NTP off, manually set the time to be close enough, turn NTP back on:

Set NTP Service inactive

$ timedatectl set-ntp false

Set the time manually

Yeah, that's sad but it works and you don't need to muck around installing anything and make it work. Get the approximate LOCAL time from the wall clock, your phone, the Internet. It doesn't need to be perfect because we'll turn ntp back on in a moment...

$ sudo timedatectl set-time "2019-06-22 13:41:00"

Set NTP service active

$ sudo timedatectl set-ntp true

Wait

john@mybox:~$ timedatectl
               Local time: Sat 2019-06-22 13:49:53 AEST
           Universal time: Sat 2019-06-22 03:49:53 UTC
                 RTC time: Sat 2019-06-22 03:49:54
                Time zone: Australia/Sydney (AEST, +1000)
System clock synchronized: no
              NTP service: active
          RTC in local TZ: no

The "System clock synchronized: no" will turn to "yes" when it has adjusted enough to be considered 'in sync'.

Trouble shooting

$ cat /etc/systemd/timesyncd.conf
[Time]
NTP=pool.ntp.org

$ timedatectl timesync-status
       Server: 13.210.208.89 (au.pool.ntp.org)
Poll interval: 8min 32s (min: 32s; max 34min 8s)
 Packet count: 0

$ grep systemd-timesyncd /var/log/syslog | tail
Jun 22 14:13:09 meebox systemd-timesyncd[8333]: Timed out waiting for reply from 103.214.220.220:123 (au.pool.ntp.org).

My ntp packets were being blocked by the corporate firewall.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.