0

I have a NAS device with 2 iSCSI LUNs.

These LUNs will only ever be used with one server so no switch is involved. I simply ran a Cat6 cable from a 10GbE port on the Server to a 10GbE port on the NAS.

From the Windows Server, I launch the iSCSI initiator, enter the IP address of the NAS and it finds both targets. I was able to connect to the first one.

When I launch the iSCSI Initiator again, entering the same IP address (for the NAS), now the list shows both Targets; one says 'Connected' and the other one says 'Inactive'

I select the one that says 'Inactive' and click Connect. After about some time I get an error message 'Unable to login to the target'

Does each iSCSI LUN need to have its own IP address on the same subnet? (Remember in this scenario, there are 2 LUNs on one Synology NAS)

  • I select the one that says 'Inactive' and click Connect. After about some time I get an error message 'Unable to login to the target' - Do you have authentication enabled on the target in question? – joeqwerty Jan 15 at 0:42
1

Each LUN does not have its own IP address.

The NAS itself has the IP address and should be entered on the Discovery tab under Target Portals. To add a target portal click the Discover Portal button and add the IP address of the NAS.

Once the Target Portal is defined go back to the Targets tab and click Refresh under Discovered targets. You should see both of your LUNs. Select the first one and click the Connect button. Ensure that the check box to "Add this connection to the list of Favorite Targets ..." is checked. Click OK. Repeat for your second LUN.

  • Hi Tim. Thanks for the clarification. The IP of the NAS appears in the Target Portals list. When I connected the first LUN (that one worked without a problem), the checkbox 'add to favorites' was checked by default. – E C Jan 14 at 23:03
  • When I go to the Targets tab, I see the second LUN in the list of Discovered Targets but it says 'Inactive'. When I click the Disconnect button, the second LUN still remains in that list and remains with status 'Inactive'. – E C Jan 14 at 23:10
  • 1
    Disconnect would disconnect the connection to that target if there were an active session, but there isn't, hence why it's listed as Inactive. – joeqwerty Jan 15 at 0:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.