0

I am trying to install Magento 2.3 on a windows server (IIS with PHP installed - No XAMP), but the installation seems to hang.

  • The wizard progress shows the following: (And has been for hours)

Starting Magento installation: File permissions check...

Required extensions check...

Enabling Maintenance Mode...

Installing deployment configuration...

Installing database schema: Schema creation/updates:

  • Data and tables do get created in the specified DB. DB has 184 tables in it...
  • I have no PHP errors reported in my PHP Log file.
  • The Magento Installation mentions an "install.log" file that is mean to be written to the PHP temp folder. Ref: Magento Install Doc . However, I do not see this log file in the PHP temp folder (I have confirmed the location in PHP settings).
  • I did, however, find an "install.log" file in the Magento \var\log folder. This file shows only the exact info that is displayed in the wizard. (As above)

\var\log\install.log ->

<span class="text-info">Starting Magento installation:</span><br><span class="text-info">File permissions check...</span><br><span class="hidden">[Progress: 1 / 757]</span><br><span class="text-info">Required extensions check...</span><br><span class="hidden">[Progress: 2 / 757]</span><br><span class="text-info">Enabling Maintenance Mode...</span><br><span class="hidden">[Progress: 3 / 757]</span><br><span class="text-info">Installing deployment configuration...</span><br><span class="hidden">[Progress: 4 / 757]</span><br><span class="text-info">Installing database schema:</span><br><span class="text-info">Schema creation/updates:</span><br>

Progress bar also stuck at 0%.

Any ideas?

  • Do the tables contain data? Is there a firewall on or between the magento and the database server. Any info on the DB? Perhaps you don't have permission to write to the PHP temp folder? – Gerard H. Pille Jan 16 at 11:35
  • MySQL is local to IIS / PHP. (So no firewall issues) There does not appear to be any data. I have not checked that the magento install can write to the php_temp folder, but I did get a php error on a previous run when env.php was not writable. No errors now tho... – Louis van Tonder Jan 16 at 11:46
  • Have the tables been created by the current installation? Anything in the mySQL logs? What is "php_temp" ? According to the installation manual you should check sys_temp_dir (devdocs.magento.com/guides/v2.3/install-gde/install/web/…) – Gerard H. Pille Jan 16 at 12:26
  • Yes, the setup wizard creates the tables.... I set php temp variable to windows\temp . This is also where the php log gets written to. – Louis van Tonder Jan 17 at 7:02
  • But the install doesn't use the "php temp variable". Run the checks as the guide says. – Gerard H. Pille Jan 17 at 8:43
0

I eventually got it working by basically disabling any and all limits on my application pool for this site in IIS. Even then, I had to try multiple times between hangs. Luckily, this time it continued off where it last hung...

Must be IIS that the magento setup has trouble with.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.