In a Win 10 workstation I have 4 drives and need some drive/partition guidance.

Disk 1 has the 100MB EFI system partition, a 2nd 1.8TB partition with data, and a 450 MB partition following that with no drive letter assigned.

Disk 2 has a single 1.3TB partition and is classified as the Primary.

Disk 3 is a new 7.2TB drive on which I'd like to migrate Disks 1 and 2 to.

Disk 4(ssd) contains a 1TB partition on which Windows is installed.

I've tried booting directly off of disk 4 and it does not have the Windows startup files on it. That was a bit surprising as I had installed Win 10 on it originally as the only drive in the machine.

I'd like to make Disk 4 bootable, and if needed, create an EFI system partition on disk 3.

How do I make disk 4 bootable? Is it possible to create an EFI system partition on disk 3? Apparently they cannot be copied from one drive to another.

Thanks much!


  • That doesn't make sense. If you put the EFI partition on disk 3, then it is disk 3 that is "bootable". If you want disk 4 to be "bootable" then you put the EFI partition on disk 4. Of course, if the disks aren't being removed, then it doesn't matter much which is "bootable". There is no "bootable" flag on disk, as there was with legacy DOS partitioned disks. EFI boots from an EFI partition, regardless of which disk it's on. – Michael Hampton Jan 18 '19 at 0:23

If you are using diskpart, the create partition efi command (see the documentation) should allow you to create a UEFI partition.

You can then format the partition and assign it a drive letter:

format fs=fat32 quick
assign letter=v

From the Windows command line, bcdboot can then be used to create the boot files:

bcdboot c:\windows /s v: 

It would be easiest to do this on disk 3 because it is new, but if you really want the bootable disk (i.e., the disk with the UEFI partition) to be disk 4 then you will need to shrink the existing Windows partition to make room for the new one. On a UEFI computer, you cannot boot directly to the Windows partition, because UEFI boot partitions must be FAT32 and the Windows partition must be NTFS.

  • Thanks so much! I had missed assigning a drive letter and as a result the bcdboot command I'd used choked. This worked beautifully. Much appreciated. – Ben Jan 22 '19 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.