1

Windows Server 2016 RDS setup. Using GPO to set preferences for IE-11 for the RDS users. (User Settings > Preferences > Control Panel Settings > Internet Settings).

The settings I want to apply is to enforce a proxy and set address + proxy overrides.

The policy (preference) applies as shown in the Resultant Set of Policy wizard. I can see the XML generated in the GPO preferences and it shows what I entered in the GPO Internet settings screens. On the target computer (the RDS session host), when looking in the registry, they keys mentioned in the XML above are factually set as they should (EnableProxy / ProxyAddress / ProxyOverride).

However, when starting Internet Explorer, it does not ask for proxy credentials, and it definitely does not use the proxy.

gpupdate /force and restarts do not change anything in this situation.

I have applied and re-applied and restarted the concerned computers 20 times by now. There is no change.

The point is that it was working in the past. It does not work now. The only change which might be related is that I installed Google Chrome, added the Chrome ADMX templates (thereby creating a Central Store for GPO templates), and then I had to copy the built-in templates into that same store from the local folder on the DC. The above policy was applied before that Google Chrome change and was working. Seems it is not working afterwards. Re-applying that policy does not seem to help anything.

It is curious that the registry on that session host server shows the settings applied (for that logged-in user, i.e. in HKEY_Current_User), yet IE-11 does not bother to use them.

Anyone have any idea or seen this behaviour?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.