3

I'm using vmware ESXI 6.7 (also known as vSphere Hypervisor) on a 64-bit Dual Socket server (2x Xeon X5672, 16 GB RAM). I've got two guests running on it, both CentOS 7 machines (64-bit).

Problems start, when I'm using the web-console, which is the preferred option to administer an ESXi-host according to vmware. It seems to me that the keyboard layout is completely screwed up.

I'm using the German layout on the CentOs-machines and also for the pop up console in-browser. It does not recognise |, @, {, }, [, ] and many other Alt Gr-characters.

The problem occurs across all major browsers, from Opera 57 over Firefox 64 and the old Microsoft IE. And because my passwords contain those characters, I'm unable to login (no, it's not a typo on the passwords). E.g. if trying to use VMRC client from Windows, I cannot login due to that issue.

Does anybody have a workaround?

  • My workaround was to use the VMRC as myselft I have a french-canadian keyboard, strange if it doesnt work for you – yagmoth555 Jan 18 '19 at 15:33
  • Same here, I use now sole and only the VMRC and not the web console. Though it was a bit tricky to change the password, it works now - at least from the VMRC. Shame on vmware. I was almost ready to call some innocent vmware support team members to exaggerate my rage about this issue. – Yannik Z. Jan 18 '19 at 15:50
2

So, it turned out that using the VMRC client (e.g. for Windows) which you can reach/start through the web client, is the only option (at least the only one I found/suggested by @yagmoth555) to get all characters working like they should.

Just click on "Actions" > "Console" > "Open Remote Console" (if you haven't installed VMRC on your local computer, do so by clicking "Download VMRC" first): Screenshot: How to open VMRC from web client

Your browser will prompt "Open .vmrc link in application?". Click on "Yes" (additionally check the checkbox to set as default procedure if clicking on .vmrc links).

VMRC will probably throw a security warning about an invalid client certificate at first start due to the unknown and not CA-signed certificate generated by ESXi. You can trust it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.