1

I have four devices on the same network on the same domain.

  • Server1
  • Server2
  • Workstation1
  • Workstation2

All devices have PSRemoting enabled. Server1 can Enter-PSSession on Server 2. Server2 can Enter-PSSession on Server 1, the same goes with Workstation2. But Workstation1 cannot Enter-PSSession onto either Server1 or Server2.

What happens when I try to Enter-PSSession FROM Workstation1 is nothing. Literally nothing. No error logs, no error messages. The shell just hangs. Or, when using New-PSSession in ISE, ISE doesn't freeze, but it just hangs on completing a Invoke-Command basic script.

Here's what I've tried to do to fix Workstation1

  • I noticed the local administrator account was disabled and did not have a password set. This created some issues for my Domain Admin account. So I set the Administrator account password, enabled it, and restarted. This fixed a lot of problems. But nothing with PSSession.

  • I set Server1 and Workstation1 as trusted hosts using the the following command winrm s winrm/config/client '@{TrustedHosts="ComputerName"}'. No errors are thrown, both are trusted. Still nothing.

  • I test WinRM between Server1 and Workstation1 with the following command test-wsman -ComputerName Server1 the test returns with successful results. No errors are returned.

  • I set the IdleTimeout for WinRM to 18 seconds using the following command: winrm set winrm/config/winrs '@{IdleTimeout="18000"}' still nothing

Nothing worked. One thing I noticed was that Server1 and Server2 are running Powershell4.0 Build 6.3, and Workstation1 is running Powershell5.1.1629, Build 10.0. I can't find any documentation on why this would matter. I'm beginning to think it's something in the registry.

  • What is the subnet arrangement for these devices? Can Workstation1 PSR to itself, or Workstation2? Check the WinRM event log on Workstation1 @ Microsoft/Windows/Windows Remote Management/Operational. I forget if its enabled by default, or if you need to right click to enable it. – Clayton Jan 22 at 17:16
  • Use set-psdebug to enable debug output and see where it's failing or hanging. – Colyn1337 Jan 22 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.