0

Rolling update for an instance group fails with "Invalid Fingerprint" error message at console. Earlier rollouts had no issues but observing this error since today and updates are failing.

Any clues please?

Thanks

0

Please use the command-line rolling update:

gcloud beta compute instance-groups managed rolling-action start-update <instancegroupname> --version template=<templatename> --zone asia-southeast1-b 
  • command-line rollout worked! Console still shows the error but updates are in place through command-line. Thanks for helping out with this. – lonewolf Jan 21 at 4:59
1

Currently, our Internal Compute Engine team working on the issue, The current workaround is to use the gcloud command which should also fix the issue on the Cloud Console afterwards. you can do a rolling replace using: gcloud beta compute instance-groups managed rolling-action replace [instance group]

You can find the details of the command at this link. Also, you can keep an eye for complete resolution of the issue at this public issue tracker link where other users field a defect report. I must also mention that Updating Managed Instance Group is a beta feature as of now.

0

Same problem here! It's possibile only in the terminal way?

gcloud beta compute instance-groups managed rolling-action start-update <instancegroupname> --version template=<templatename> --zone asia-southeast1-b 

This is the correct code? It' can't work for me! (I have already a instance-group "example" and a template "example-template" created)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.