2

I'm working on setting up PXE boot server and while following some online instructions to mount the ISO and copy over everything under /mnt/install/netboot/, I noticed that a mount of ubuntu-18.04.1.0-live-server-amd64.iso is missing the install/netboot/ directory, whereas under ubuntu-16.04.5-server-amd64.iso this directory exists.

In trying to make sure I use 18.04 files, am I looking in the wrong place of the 18.04 ISO or was this whole section dropped after 16.04?

ubuntu-16.04.5:

alby@ubuntu:/$ sudo mount -o loop /var/tmp/ubuntu-16.04.5-server-amd64.iso /mnt

alby@ubuntu:/$ ls -l /mnt/install/netboot/
total 3
lr-xr-xr-x 1 root root   47 Jul 30 22:25 ldlinux.c32 -> ubuntu-installer/amd64/boot-screens/ldlinux.c32
lr-xr-xr-x 1 root root   33 Jul 30 22:25 pxelinux.0 -> ubuntu-installer/amd64/pxelinux.0
lr-xr-xr-x 1 root root   35 Jul 30 22:25 pxelinux.cfg -> ubuntu-installer/amd64/pxelinux.cfg
dr-xr-xr-x 1 root root 2048 Jul 30 22:16 ubuntu-installer
-r--r--r-- 2 root root   61 Jul 30 22:24 version.info

ubuntu-18.04.1.0:

alby@ubuntu:/$ sudo mount -o loop /var/tmp/ubuntu-18.04.1.0-live-server-amd64.iso /mnt

alby@ubuntu:/$ ls -l /mnt/install/
total 179
-r--r--r-- 1 root root 182704 Jan 28  2016 mt86plus
alby@ubuntu:/$ 
  • What do you mean by mini.so? Or do you mean min.ISO? I'm using full ISO files and the 18.04 doesn't appear to have the pxeboot files,whereas the 16.04 version does. I can only assume I need to use 16.04, because I just don't see where these files exist in 18.04. – Alby Jan 20 at 14:06
2

I am taking a similar online course and had the same issue.

What worked for me was to go to the Download section in www.ubuntu.com.

From the Ubuntu Server I choose "Use the traditional installer" link.

From there I scrolled up to "Network installer" and I choose the version that I wanted (18.04 LTS in my case).

It took me to a page with various architectures where I choose what worked for me (amd64 in my case).

From there I downloaded netboot.tar.gz and I extracted the content in to /var/lib/tftpboot.

With the dhcp and tftp active and properly configured I managed to boot a VM from Lan (as a boot method). It brought me to the Installer boot menu and I completed an installation of a ubuntu-basic-server.

I hope it helped.

https://www.ubuntu.com/download/alternative-downloads#alternate-ubuntu-server-installer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.