2

As a purpose of testing, I am trying to spin up instances of large size, I mean of 8 vCPU's and greater than 20 GB memory, with 50 GB storage. Physical host has 48 GB RAM and 16 CPU. But everytime receives the same error

Failed to perform requested operation on instance "TestBigVM", the instance has an error status: Please try again later [Error: No valid host was found. There are not enough hosts available.].

In nova compute log, this is the last entry, and can't see any errors:

2019-01-20 22:39:46.447 16511 INFO nova.compute.resource_tracker [req-ded356b5-7a71-451d-a834-db9e696b07dd - - - - -] Final resource view: name=openstack.xxyyzz.com phys_ram=49139MB used_ram=512MB phys_disk=49GB used_disk=0GB total_vcpus=16 used_vcpus=0 pci_stats=[]

Have googled so many links like https://ask.openstack.org/en/question/54326/cant-create-instance-no-valid-host-was-found-nova-compute-is-not-running/ and then also tried virt_type=kvm or qemu, but everything failed.

Is there any alternative or legitimate solution for this.? Stuck in between some task and this is very critical for the assigned task. Any help would really be appreciated.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.