2

this should be a trivial issue, except this time it isn't.

I have a folder on a non-boot drive in a Windows Server 2008 R2 machine which is completely stuck. Using the domain administrator account, I'm unable to:

  • delete it
  • take ownership of it (takeown gives ERROR: Access denied!!)
  • change the permissions on it (access denied)

When checking the effective permissions it shows that:

  • Administrator (Domain Admin) has FULL permissions on the folder
  • The Domain Admins group also has FULL permissions

But in the security tab it shows that the Domain Admins group lacks the Special Permissions.

The folder does not inherit its ACLs from the parent, while its children inherit its ACLs.

The owner (which is not the domain admin but a random domain user) has the following rights on it:

  • read permissions
  • change permissions

Except that not even logging onto the server with the owner credentials will allow me to change the permissions or the owner. I always get ACCESS DENIED when using icacls or takeown. And this really doesn't seem to make much sense to me!

Chckdsk found no issues of course. There are no open sessions locking this folder. I tried using RUNAS, booting to safe mode, logging in as the owner.. nothing has worked so far.

Is there a way to forcefully strip away any ACL from a NTFS folder? The content has been copied, so I'm also happy to just nuke it. But it's over 8gb of data and I'd like to get rid of it.

Thank you for your help

SOLVED!! I should have said that this folder was previously a member of a DFS replication group which went rogue. The replication group had been replaced. It left behind some leftovers in the LDAP structure which I cleaned up. But unfortunately for some reason the new replication group (which bore the same names of the old one and the same targets of the old one except for the folder in question), ketp this folder as its target instead of the new one which I assigned to it. When I realized this I removed the server on which this folder resides from the replication group and the folder from the namespace. After doing this I was able to delete it.

Thank you all

  • Try running icacls /c /t /reset on the folder. – joeqwerty Jan 22 at 15:45
  • Running that command in an Elevated Prompt I'm getting an Access Denied Error on every file – Valentino Jan 22 at 16:29
  • Could there be a service or application running that is actively using the files in this directory? Post here shows how to detect open file locks serverfault.com/questions/1966/… – Clayton Jan 22 at 17:32
  • Have you tried taking ownership of the folder first? – Tim Liston Jan 22 at 19:53
  • Sound like AV to me. If the administrator cannot take ownership of a file or folder: 1) AV 2) another process actively blocking it [see procexplorer] 3) driver failure 4) data storage failure. – bjoster Jan 25 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.