6

I am using Windows 10 professional, connected to office domain network.

I just enabled Hyper-V program with other related features in Windows Features. Hyper V and related program in Windows feature

After reboot computer, I click Connect to Server in Hyper-V

Then I got an error message: related to Virtual Machine Management The message says:

Hyper-V Manager "An error occurred while attempting to connect to server XX. Check that the Virtual Machine Management service is running and that you are authorized to connect to the server

I have googled everywhere, but there is no result. The closest post I could find is from this GitHub web link: GitHub.

Could anyone suggest how to solve this issue so I could begin using Hyper-V program?

Take note that I have switched my internet to a public WiFi and it still shows the same error message.

Update 01: Hyper-V Virtual Machine Management is running in Services.msc

Update 02: My Hyper-V Manager version is 10.0.17763.1. My colleague managed to get his Hyper-V Manager working and his version is 10.0.17134.1

5
  • Check that the Virtual Machine Management service is running and that you are authorized to connect to the server – Sum1sAdmin Jan 25 '19 at 14:52
  • @Sum1sAdmin, do you mean Hyper-V Virtual Machine Management in services.msc? If yes, I have started that service and still get the same error message. – hunterex Jan 25 '19 at 14:56
  • Check the Windows event log for relevant errors. – Michael Hampton Jan 25 '19 at 15:33
  • @MichaelHampton, could you please suggest which activity in Windows Event Viewer should I look for? – hunterex Jan 25 '19 at 15:48
  • @Sum1sAdmin should I then try google? Thanks Tips ;) – FreeSoftwareServers Mar 6 at 22:24
3

I managed to solve the problem.

Main reason behind this issue: Hyper-V Host Compute Service service fails to start with an error message quoted from Event Viewer:

The Hyper-V Host Compute Service service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion.

So I followed the steps in Hyper-V Manager unable to connect to server "Local computer" solution. Please ensure you run Powershell as an administrator.

After that, I manually start:

  • Hyper-V Virtual Machine Management
  • Hyper-V Host Computer Service

When I start Hyper-V Manager, I successfully connect to Local Computer.

1
  • Link Only Answers are frowned upon for good reason, links go dead. Please input details into answer. – FreeSoftwareServers Feb 20 '20 at 18:50
1

We recently had the same issue. Resolution was:

  1. Open PowerShell as administrator
  2. Execute Set-ProcessMitigation -Name VMCompute.exe -disable CFG
  3. Reboot
0

Steps from the link above Hyper-V Manager unable to connect to server "Local computer"

  1. Open "Window Security"

  2. Open "App & Browser control"

  3. Click "Exploit protection settings" at the bottom

  4. Switch to "Program settings" tab

  5. Locate "C:\WINDOWS\System32\vmcompute.exe" in the list and expand it

  6. Click "Edit"

  7. Scroll down to "Code flow guard (CFG)" and uncheck "Override system settings"

  8. Start vmcompute from powershell net start vmcompute

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.