1

I'm new to AWS and the AWS console. I appear to have somehow really messed up my settings. My client wants to use AWS S3 as a hosting platform for his podcast, but I cannot upload any file with public-read permissions.

To tackle this problem I have attempted changing the bucket policy to the following (as root user):

{
  "Version":"2012-10-17",
  "Statement":[
    {
      "Sid":"AddPerm",
      "Effect":"Allow",
      "Principal": "*",
      "Action":["s3:GetObject"],
      "Resource":["arn:aws:s3:::[bucketname]/*"]
    }
  ]
}

However, when I try to save the new policy, I get an Access Denied message. As for the policy that is already in use: there isn't one. It's just a blank field.

2

If you're the root user and you're getting access denied, you clearly should have any permissions problems as such, but I'm guessing it is an extra layer of protection against accidental public access that AWS have introduced.

They announced "Block public access" feature in Nov 2018 to improve the security of S3 buckets. See the blog article https://aws.amazon.com/blogs/aws/amazon-s3-block-public-access-another-layer-of-protection-for-your-accounts-and-buckets/

Assuming that's what is causing it, you should be able to change this setting on the bucket first, then you will be able to configure the bucket policy.

  • I tried a bunch of things and it eventually worked. Your answer wasn't the final solution, but it must have helped. Thank you. – gilbert-v Jan 30 at 9:45
2

If "Block new public ACLs and uploading public objects (Recommended)" under public access settings of bucket is set to true, you will not be able to add any new ACL's granting public access. screenshot of public access setting in a bucket page

  • 1
    Thanks, but I'd already tried that. – gilbert-v Jan 30 at 9:45
  • Can you please share how you solved the issue or what caused the error? – Priya R Jan 30 at 13:26
  • I'm afraid I can't as I'm still not sure what the issue was. – gilbert-v Jan 30 at 14:09
  • oh well then... – Priya R Jan 30 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.