2

I'm trying to pull from bitbucket through Jenkins in our AWS windows server. Jenkins is using the System User so I need to accept the host key in order for it to work because Jenkins doesn't provide user input for me to enter yes. I used psexec command to run cmd as System User, then opened git bash from there so that I can use it as a System User. I then tried putty -ssh git@ourURLthatwasProvided -P 7999 and recieved this error

Discounnecte: No Supported Authentication methods availbale
shell request failed on channel 0

I am not sure what that means. After researching online, I tried this command to see if it was connecting

ssh -Tv git@ourURLthatwasProvided -P 7999

In the log, it says

Authentication succeeded (publickey).
Authentication to bitbucket
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: pledge: network
shell request failed on channel 0

Any help is appreciate it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.