3

(Sorry for bad english) I'm attempting to use esxcli to upgrade my host from ESXI 6.0 to 6.7 because of some added features. Whenever I run

esxcli software profile update -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml -p ESXi-6.7.0-8169922-standard

[DependencyError] VIB VFrontDe_bootbank_net51-r8169_6.011.00-2vft.510.0.0.799733 requires vmkapi_ 2_1_0_0, but the requirement cannot be satisfied within the ImageProfile. VIB VFrontDe_bootbank_net51-sky2_1.20-2vft.510.0.0.799733 requires vmkapi_2_1_0 _0, but the requirement cannot be satisfied within the ImageProfile. Please refer to the log file for more details.

EDIT: After attempting to upgrade to 6.5 first, as suggested by the first comment, running this command esxcli software profile update -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml -p ESXi-6.5.0-20180502001-standard

I get a different error: [InstallationError] [Errno 28] No space left on device vibs = VMware_locker_tools-light_6.5.0-1.47.8285314 Please refer to the log file for more details.

  • 1
    Try to uograde to 6.5, after to 6.7 – yagmoth555 Jan 29 '19 at 2:05
-1

So upon further research, I had to install the VIB that was causing problems manually, then go through with the upgrade to 6.5. Now upon rebooting, YAY I'm at 6.5. I'll link to where I found the answer. experts-exchange

  • If this answer solves your request, you can mark it as accepted answer. – Tobias Jan 29 '19 at 6:31
  • 1
    And please add the essential parts from that link to your answer. The answer becomes useless if that link goes dead some day. – Gerald Schneider Jan 29 '19 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.