0

Recently I have installed geonode on apache tomcat8 in an Ubuntu 16.04 droplet on digitalocean . Everything worked without any issue. The service was up and running.

Then I tried to enable SSL for that installation by following the steps outlined here. I have actually completed all the steps with no issue again, however, the problem is since the certificate is self signed i.e. it is not provided by a recognized SSL provider, I still do not have a SSL enabled service.

Does anyone know how to deal with this kind of issues in cheapest possible way, such as using lets-encrypt.

0

Yes, if you are using self signed certificate then browser will show the warning for it and use of self signed certificate has drawbacks too. So it is good choice to get SSL only from trusted certificate authority or its resellers (if you need cheapest possible way). See difference between Self Signed SSL & Certificate Authority

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.