0

Did some testing with Azure SRM. Made a active replication in a Testvault. Afterwards try to delete this vault, because an active retention policy cannot be deleted.

Resourcegroup ->Recovery-> Testvault-> Site Recovery infrastructure-> Replication policy -> 24-hour-retention-policy.

Try to delete it:

Delete replication policy You cannot delete this replication policy as there are one or more Azure virtual machines using this policy.

But in this subsciptions are no active machines anymore!

Also tried a force delete: https://docs.microsoft.com/en-us/azure/backup/backup-azure-delete-vault#delete-a-vault-used-to-protect-a-production-server

But also same error.

{ "error": { "code": "ServiceResourceNotEmpty", "message": "Vault cannot be deleted as there are existing resources within the vault.\nPlease delete any registered servers, Hyper-V sites (Used for Site Recovery), policy associations for SCVMM clouds (Used for Site Recovery) and then delete the vault.", "target": null, "details": null, "innerError": null } }

Can someone help?

0

You need to delete any backups in the vault before you can delete it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.