I have installed php 7.2 on centos 7. I tried to install the module redis but it seems id doesn't want to download. Here is the error of the command yum install php-pecl-redis :

enter image description here

I tried installing it with yum install php72w-pecl-redis but it seems like it doesn't found the package.


You installed PHP from the remi-php72 repository, but then you disabled that repository. Enable it and try installing php-pecl-redis again.

  • Here is the content of the file /etc/yum.repos.d/remi-php72.repo pastebin.com/nN6tsZn4 – executable Feb 2 at 16:20
  • Now post the output from trying to install the package again. And please don't use screenshots. Copy and paste text. – Michael Hampton Feb 2 at 16:22
  • Also notice than you probably need php-pecl-redis4 for latest version – Remi Collet Feb 4 at 6:36

I would

yum install php-pecl-redis --disablerepo=* --enablerepo=remi-php*

granted that you still have /etc/yum.repos.d/remi-php72.repo

when cherrypicking packages from different repos you always have to do work on top.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.