0

i have the problem, that my debian 8 server where a kvm/qemu and a samba server is running has the problem, that i cant connect from any VM to the fileshare folder. i can see the host over the network path, but i cant ping it. from the other clients in the same subnet, but hardware machines i can connect without any problems (win and linux) to the samba fileshares of the server. i can connect to the VM's to without any problems.

here is the cfg for the host:

allow-hotplug enp3s0
iface enp3s0 inet static
address 192.168.8.102
netmask 255.255.255.0
network 192.168.8.0
broadcast 192.168.8.255
gateway 192.168.8.1
dns-nameservers 192.168.8.1 8.8.8.8

allow-hotplug enp5s0
iface enp5s0 inet static
address 192.168.8.104
netmask 255.255.255.0
broadcast 192.168.8.255
network 192.168.8.0
gateway 192.168.8.1
dns-nameservers 192.168.8.1 8.8.8.8

#auto br0
#iface br0 inet static
#  bridge_ports enp3s0
#  address 192.168.8.103
#  netmask 255.255.255.0
#  gateway 192.168.8.1
#  bridge_stp off
#  bridge_fd 0
#  bridge_maxwait 0

#auto br1
#iface br1 inet static
#  bridge_ports enp5s0
#  address 192.168.8.105
#  netmask 255.255.255.0
#  gateway 192.168.8.1
#  bridge_stp off
#  bridge_fd 0
#  bridge_maxwait 0
#--
## bridge_hello 2
## bridge_maxage 12
## bridge_stp off

i tried with the bridged mode too, but i had the problem to find the host in the network and so i had problems to connect to my fileshares. maybe a little wrong setting, but i couldnt find out where.

the cfg of the VM's are all bridged for enp3s0 or enp5s0 atm. Not NAT!

i dont write the cfg for the samba server, because i dont think to find the problem there.

thx for any idea how to solve that

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.