0

What I'm trying to do: I'm trying to create a small webhooks_server using 3 technologies:

  • a FreeBSD server
  • a NodeJS server
  • a process control syster (Supervisor)

When I run my test code on the FreeBSD server using node <main.js>

function intervalFunc() {
   console.log('Cant stop me now!');
}
setInterval(intervalFunc, 1500);

It works just fine:

enter image description here

Problem: As soon as I add this test-file into a Supervisor process:

;;;;;; webhooks_server ;;;;;;;
[program:webhooks_server]
command=/usr/local/bin/node /home/<usr_name>/apps/webhooks_server/test.js
process_name=%(program_name)s
directory=/home/<usr_name>/apps/webhooks_server
user=<usr_name>
numprocs=1
autostart=true
autorestart=true

I get "radio-silence", meaning: nothing shows up on the "stdout" or "stderr" channels. Furthermore, I have also tried to perform an I/O (writing to a log-file) operation and also doesn't happen (no error - just "quiet").

On my local machine all code works fine, so I suspect this is a FreeBSD/Supervisor setup problem.

Question: What am I missing? Any suggestions/recommendations?

  • 1
    Do you have supervisord running? – arrowd Feb 3 '19 at 6:36
  • @arrowd, yes; I can start, restart, stop (etc) processes using "supervisorctl" – Nactus Feb 3 '19 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.