0

Two days ago, my postfix failed without any actions from me. First, I had an issue with blocked port 25. Now this is now solved: POSTFIX Won't Start says: bind 0.0.0.0 port 25: Address already in use

But my SMTP mail server mail.bilp.fr is still not available.

When I test the server with https://mxtoolbox.com/SuperTool.aspx?action=smtp%3amail.bilp.fr&run=toolpage# it goes to a Failed to connect

Also, my GMAIL can't send thru my server.

service postfix status:

postfix.service - LSB: Postfix Mail Transport Agent
   Loaded: loaded (/etc/init.d/postfix)
  Drop-In: /run/systemd/generator/postfix.service.d
       └─50-postfix-$mail-transport-agent.conf
   Active: active (running) since Sun 2019-02-03 10:36:04 CET; 9min ago
  Process: 2438 ExecStart=/etc/init.d/postfix start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/postfix.service
           ├─ 2569 /usr/lib/postfix/master
           ├─ 2570 pickup -l -t unix -u -c
           ├─ 2571 qmgr -l -t unix -u
           ├─ 8581 tlsmgr -l -t unix -u -c
           ├─ 8582 anvil -l -t unix -u -c
           ├─10426 smtpd -n 188.165.253.141:smtp -t inet -u -c -o stress= -o smtpd_sasl_auth_enable=yes
           ├─10427 proxymap -t unix -u
           ├─10550 cleanup -z -t unix -u -c
           ├─10551 trivial-rewrite -n rewrite -t unix -u -c
           └─10552 local -t unix

Feb 03 10:45:02 ns339072.ip-188-165-253.eu postfix/pickup[2570]: D3349BFD0F: uid=33 from=<www-data>
Feb 03 10:45:02 ns339072.ip-188-165-253.eu postfix/cleanup[10550]: D3349BFD0F: message-id=<20190203094502.D3349BFD0F@mail.bilp.fr>
Feb 03 10:45:02 ns339072.ip-188-165-253.eu postfix/qmgr[2571]: D3349BFD0F: from=<www-data@bilp.fr>, size=863, nrcpt=1 (queue active)
Feb 03 10:45:02 ns339072.ip-188-165-253.eu postfix/trivial-rewrite[10551]: warning: do not list domain bilp.fr in BOTH mydestination and virtual_alias_domains
Feb 03 10:45:03 ns339072.ip-188-165-253.eu postfix/local[10552]: D3349BFD0F: to=<www-data@bilp.fr>, orig_to=<www-data>, relay=local, delay=0.65, delays=0.01/0/0/0.64, dsn=2.0.... $LOGNAME)
Feb 03 10:45:03 ns339072.ip-188-165-253.eu postfix/qmgr[2571]: D3349BFD0F: removed
Feb 03 10:45:28 ns339072.ip-188-165-253.eu postfix/smtpd[10426]: connect from unknown[185.234.218.38]
Feb 03 10:45:31 ns339072.ip-188-165-253.eu postfix/smtpd[10426]: warning: unknown[185.234.218.38]: SASL LOGIN authentication failed: authentication failure
Feb 03 10:45:31 ns339072.ip-188-165-253.eu postfix/smtpd[10426]: lost connection after AUTH from unknown[185.234.218.38]
Feb 03 10:45:31 ns339072.ip-188-165-253.eu postfix/smtpd[10426]: disconnect from unknown[185.234.218.38]

I use GMAIL with alias accounts. So GMAIL tries to connect to my mail.bilp.fr and I think that those connect from unknown[185.234.218.38]are the GMAIL attempts to connect to my server?

But I don't see why others failed to connect to mail.bilp.fr?

0

Yeah! I found the reason: some lines were missing in /etc/postfix/master.cf

I had to add:

149.202.114.212:smtp    inet    n   -   -   -   -   smtpd -o smtpd_sasl_auth_enable=yes -o smtpd_tls_cert_file=/home/bilp/ssl.cert -o smtpd_tls_key_file=/home/bilp/ssl.key
149.202.114.212:submission  inet    n   -   -   -   -   smtpd -o smtpd_sasl_auth_enable=yes -o smtpd_tls_cert_file=/home/bilp/ssl.cert -o smtpd_tls_key_file=/home/bilp/ssl.key

The point is: this server had been installed 6 months ago, and POSTFIX worked fine until then. I cannot understand how POSTFIX could work without those 2 lines?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.