1

SysInfo:

  • ubuntu 18.04
  • external access point (with its own internal linux system) => interface ap1, IP: 192.168.13.1
  • external access point (USB stick) => interface ap0, IP: 192.168.12.1
  • hostapd running on ap0
  • dnsmasq running without being binded to any interface bc I need it to work on both interfaces
  • DNS must work on local-network only.

The problem is that when I connect through the ap1 and type "mydomain.com" on my browser it's not working unless I have the USB stick (ap0) attached and working.

IDK if the issue is with hostapd itself or dnsmasq.

My dnsmasq.conf:

localise-queries
resolv-file=/etc/dnsmasq.resolv.conf
no-hosts
addn-hosts=/etc/my.hosts
dhcp-range=192.168.12.20,192.168.12.150,255.255.255.0,12h
dhcp-range=192.168.13.20,192.168.13.150,255.255.255.0,12h
dhcp-option=option:domain-search,local
bind-dynamic

The addresses in the my.hosts file are setup like this:

<IP>\t<DOMAIN>

In that file I have all the addresses for both interfaces 192.168.12.1 and 192.168.13.1)

How do I make it work for both interfaces?

Ask for any extra information.

2

You need to specify dnsmasq which interface to use what network. You can do this with below change in your dnsmasq.conf file:

dhcp-range=ap0,192.168.12.20,192.168.12.150,255.255.255.0,12h
dhcp-range=ap1,192.168.13.20,192.168.13.150,255.255.255.0,12h

or,

dhcp-range=interface:ap0,192.168.12.20,192.168.12.150,255.255.255.0,12h
dhcp-range=interface:ap1,192.168.13.20,192.168.13.150,255.255.255.0,12h
1
  • The interface: argument has been removed from dnsmasq in 2.63 it seems. – Coroos Oct 7 '20 at 7:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.