0

I have a Windows 2016 Server and I need to read the Windows Update log file. So I ran the Get-WindowsUpdateLog PS command and the outputted file said No Format Information Found. So I then ran the following command to convert the .ETL files directly:

tracefmt.exe -o updates.log WindowsUpdate01.etl -r srv*c:\symbols*https://msdl.microsoft.com/download/symbols

The command did run but the output was the same as before with No Format Information Found entries. tracefmt.exe also outputted the following:

Processing completed Buffers: 4, Events: 119, EventsLost: 0 :: Format Errors: 0, Unknowns: 113

So i'm guessing the 113 Unknowns are because the symbols can't be converted.

As a test I ran exactly the same tracefmt.exe command on a Windows 10 PC and was able to convert its .ETL files successfully. The tracefmt.exe file i'm using is from the Windows 10 WDK.

Does anyone know why I can't convert the .ETL file? Does Server 2016 require a different tracefmt.exe version than Windows 10?

Thanks, Jason

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.