0

I've inherited a few Ubuntu 14.04 hosts which are configured with Shibboleth auth through Apache. They run rails/apache. The installed packages(1) on these hosts is libapache2-mod-shib2 along with a few files(2) under /etc/shibboleth which look new/modified/added.

Trying to upgrade these hosts to 16.04 but one of our devs mentioned shibboleth 2 is deprecated. I pulled up a page on switch.ch which only shows a SWITCH repo of SP3 for 18.04 (radio button under Introduction) but then about half-way down the page (under Add Repository) there are directions for adding a 16.04 repo. Is this a typo? I'd rather just upgrade to SP3 and not have to screw around with installing 18.04 if possible.

(1)

libapache2-mod-shib2
liblog4shib1v5:amd64
libshibsp-plugins:amd64
libshibsp7:amd64
shibboleth-sp2-common
shibboleth-sp2-utils

(2)

sp-key.pem
sp-cert.pem
shibboleth2.xml

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.