1

I am having trouble installing Remote Desktop Services after upgrading from Server 2012 to Server 2019. I had Remote Desktop Services installed on 2012, but the rds-web-access role was not functioning. I tried to remove all remote desktop roles and start over, but the rds-web-access roles keeps failing when I try to install using Install-WindowsFeature RDS-Web-Access -IncludeAllSubFeature:

  • Install-WindowsFeature RDS-Web-Access -IncludeAllSubFeature
  • + CategoryInfo          : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],
    Exception
    + FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind
    owsFeatureCommand
    

I have tried the following:

  • Installing with Server Manager GUI
  • DISM /Online /Cleanup-Image /RestoreHealth
  • DISM /Online /Cleanup-Image /RestoreHealth /Source:wim:D:\sources\install.wim:1 /limitaccess
  • sfc /scannow
  • Install-WindowsFeature RDS-Web-Access -source D:\sources\install.wim

Each time I am met with the above error. sfc /scannow keeps telling me that it found corrupted files and have successfully repaired them, even when I run sfc /scannow right after it claims to repair them, it tells me that it found corrupted files again.

The last few entries on my cbs log after attempting to install rds-web-access look like this: https://pastebin.com/GANeWPzd

The only way I got the install to succeed is if I install "Install-WindowsFeature RDS-RD-Server -IncludeAllSubFeature" before I install the rds-web-access role. If I do that though it requires a reboot and the install fails during the reboot and it will revert the changes.

Everything else, including Windows Updates, seems to be working fine. Any help or guidance is greatly appreciated.

Thanks!

  • Is that post could help ?, serverfault.com/questions/524762/cannot-install-rds-web-access if yes we can mark as a duplicate – yagmoth555 Feb 5 at 17:34
  • I found this thread. The answers did not help me. – Intrepid Feb 5 at 18:07
  • A guess, but I seen IIS error in the cbs log, as the default web site exist, can you make sure the IIS role is not installed before installing the RDWeb component ? – yagmoth555 Feb 5 at 18:09
  • You want me to try uninstalling the IIS roles before installing rdweb? – Intrepid Feb 5 at 18:21
  • Yes if you can, I dont know what the IIS role host on your server – yagmoth555 Feb 5 at 19:25
1

I was able to resolve this by performing a clean install of IIS using the steps in this guide: https://blogs.msdn.microsoft.com/friis/2017/01/16/how-to-perform-a-clean-reinstallation-of-iis/

I then had to delete the URL acl. You can view your acls with this command:

netsh http show urlacl

And delete:

netsh http delete urlacl http://+:80/ netsh http delete urlacl https://+:443/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.