I deployed wildfly to my server on a subdomain and Nginx is a reverse proxy.To secure my connection I forced wildfly to use https through 443 with a letsencrypt ssl certificate :

In the standalone.xml, I create an additional socket-binding entry. and I added a

<socket-binding name="https-external" port="443"/>

and I Changed the http-listener to redirect this https-external instead https.

It worked fine until the moment when I tried to access the admin console: I was unable to login.

I tried to modify the management-interfaces by adding a socket-binding with http="management-https"(and by default it uses the port 9993 for the management-https) but it didn't work. It looks that I'm missing something which I can't figure out.

the content of the "vhost" file of wildfly subdomain for ngnix is :

upstream wildflyadmin {
upstream wildfly {
server {
    server_name sub.domaine.com;

    access_log  /var/log/nginx/wildfly.access.log;
    error_log   /var/log/nginx/wildfly.error.log;

    proxy_buffers 16 64k;
    proxy_buffer_size 128k;

location / {
              proxy_pass http://wildfly;  

location /dashadmin/ {
              proxy_pass http://wildflyadmin;  

    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/domaine.com/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/domaine.com/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

1 Answer 1


It happened after i used a backup file of the standalone.xml . by default wldfly doesn't allow foreign access to its management console.

so the management interface should be changed to instead of

  <interface name="management">
  <inet-address value=""/>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.