0

Please help, i've tried searching the internet to solve this but i still could not make it work..

Server: Ubuntu 18.04

Client: OSX Mojave via Tunnelblick

I'm trying to connect my client machine to the samba server via OpenVPN on AWS. Incoming port is already enabled for the openVPN in the AWS security group.

VPN is connected successfully.

Tried using Finder > Go > Connect To Server

But received the following error:

enter image description here

Tried looking under Volumes but nothing was there. I was deceived.

However connecting to the SAMBA server directly with its public IP address without using openVPN was not a problem.

The samba configuration already has

hosts allow = 10.8.0.0/24 127.0.0.1
interfaces = 127.0.0.0/8 eth0 10.8.0.0/24
0

I dont understand, you can connect without VPN, so you are locally in the LAN, but it doesnt work if the openvpn client is up?

  • Then configure the openvpn to allow you to access to LAN ressource

or

  • Check your routing table, as you are in the LAN, make sure the 10.8.0.6 is not routed to your VPN gateway, add a route to make sure it go to your eth0 adapter

or

  • Dont use the openvpn when you are locally in the LAN

If you mean it worked in the LAN, but not from home with the openvpn;

  • Make sure your routing table show a line like 10.8.0.x or 10.8.0.6 to be sure the openvpn know to route that traffic there.
  • 1. I can connect to the samba server directly with public IP of the server (openVPN is not connected). had to open the SAMBA port for this temporarily. not via LAN. 2. But once i'ved connected to the openVPN and then try connect to server using the 10.8.0.x. it doesn't work and show me that error – user308133 Feb 8 at 14:04
0

Several potential issues to check here here:

  1. you will need to enable ip forwarding on the VPN gateway
  2. you will need to add a route back to the host pool via the VPN gateway on the AWS subnet
  3. you will need the outbound traffic to not be NATed for the host pool on the VPN gateway (Cisco call this "NONAT" or "IDNAT")

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.